Generalized Matrioshkas uva

Generalized Matrioshkas 

Vladimir worked for years making matrioshkas, those nesting dolls that certainly represent truly Russian craft. A matrioshka is a doll that may be opened in two halves, so that one finds another doll inside. Then this doll may be opened to find another one inside it. This can be repeated several times, till a final doll -that cannot be opened- is reached.

Recently, Vladimir realized that the idea of nesting dolls might be generalized to nesting toys. Indeed, he has designed toys that contain toys but in a more general sense. One of these toys may be opened in two halves and it may have more than one toy inside it. That is the new feature that Vladimir wants to introduce in his new line of toys.

Vladimir has developed a notation to describe how nesting toys should be constructed. A toy is represented with a positive integer, according to its size. More precisely: if when opening the toy represented bym we find the toys represented by n1, n2, ..., nr, it must be true thatn1 +n2 + ... +nr <m. And if this is the case, we say that toymcontains directly the toysn1,n2,...,nr . It should be clear that toys that may be contained in any of the toysn1,n2,...,nr are not considered as directly contained in the toym.

A generalized matrioshka is denoted with a non-empty sequence of non zero integers of the form:

a 1     a 2    ...     a N

such that toy k is represented in the sequence with two integers -k and k, with the negative one occurring in the sequence first that the positive one.

For example, the sequence

-9     -7     -2    2     -3     -2     -1    1    2    3    7    9

represents a generalized matrioshka conformed by six toys, namely, 1, 2 (twice), 3, 7 and 9. Note that toy 7 contains directly toys 2 and 3. Note that the first copy of toy 2 occurs left from the second one and that the second copy contains directly a toy 1. It would be wrong to understand that the first -2 and the last 2 should be paired.

On the other hand, the following sequences do not describe generalized matrioshkas:

  • -9     -7     -2    2     -3     -1     -2    2    1    3    7    9

    because toy 2 is bigger than toy 1 and cannot be allocated inside it.

  • -9     -7     -2    2     -3     -2     -1    1    2    3    7     -2    2    9

    because 7 and 2 may not be allocated together inside9.

  • -9     -7     -2    2     -3     -1     -2    3    2    1    7    9

    because there is a nesting problem within toy 3.

Your problem is to write a program to help Vladimir telling good designs from bad ones.

Input 

The input file contains several test cases, each one of them in a separate line. Each test case is a sequence of non zero integers, each one with an absolute value less than107.

Output 

Output texts for each input case are presented in the same order that input is read.

For each test case the answer must be a line of the form


:-) Matrioshka!


if the design describes a generalized matrioshka. In other case, the answer should be of the form


:-( Try again.

Sample Input 

-9 -7 -2 2 -3 -2 -1 1 2 3 7 9
-9 -7 -2 2 -3 -1 -2 2 1 3 7 9
-9 -7 -2 2 -3 -1 -2 3 2 1 7 9
-100 -50 -6 6 50 100
-100 -50 -6 6 45 100
-10 -5 -2 2 5 -4 -3 3 4 10
-9 -5 -2 2 5 -4 -3 3 4 9

Sample Output 

:-) Matrioshka!
:-( Try again.
:-( Try again.
:-) Matrioshka!
:-( Try again.
:-) Matrioshka!
:-( Try again.

解决方案:这个和匹配括号差不多,不过中间多了判断-k和+k之间的toys是否合理。

代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
int S[100000];//建立栈
int A[100000];
int num[100000];//记录toys里包含的大小总和(只看一层的嵌套)
int main()
{
    char s;
    int a;
    int l=0;
    while(~scanf("%d",&a))
    {

        A[l++]=a;
        if((s=getchar())=='\n'){
            S[1]=A[0];num[1]=0;
            int i,top=1;
          for(i=1;i<l;i++)
            {
            if((A[i]+S[top])==0)//当遇到两个连在一起的-k,+k时,则该k toys 里没有toy了
            {
             top--;//-k出栈
             num[top]+=abs(A[i]);//加入上一层toy的包含中
            if(top&&num[top]>=abs(S[top]))//若包含的总和大于等于toy的大小,则退出
                {
                 break;}
            }
             else {
                S[++top]=A[i];
                num[top]=0;
            }
            }
            if(!top) printf(":-) Matrioshka!\n");
            else printf(":-( Try again.\n");
            l=0;


        }
         }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值