Wine trading in Gergovia uva+贪心

Wine trading in Gergovia

As you may know from the comic "Asterix and the Chieftain's Shield", Gergovia consists of one street, and every inhabitant of the city is a wine salesman. You wonder how this economy works? Simple enough: everyone buys wine from other inhabitants of the city. Every day each inhabitant decides how much wine he wants to buy or sell. Interestingly, demand and supply is always the same, so that each inhabitant gets what he wants.

There is one problem, however: Transporting wine from one house to another results in work. Since all wines are equally good, the inhabitants of Gergovia don't care which persons they are doing trade with, they are only interested in selling or buying a specific amount of wine. They are clever enough to figure out a way of trading so that the overall amount of work needed for transports is minimized.

In this problem you are asked to reconstruct the trading during one day in Gergovia. For simplicity we will assume that the houses are built along a straight line with equal distance between adjacent houses. Transporting one bottle of wine from one house to an adjacent house results in one unit of work.

Input Specification

The input consists of several test cases. Each test case starts with the number of inhabitants n (2 ≤ n ≤ 100000). The following line contains n integers ai (-1000 ≤ ai ≤ 1000). If ai ≥ 0, it means that the inhabitant living in the ith house wants to buy ai bottles of wine, otherwise if ai < 0, he wants to sell -aibottles of wine. You may assume that the numbers ai sum up to 0.
The last test case is followed by a line containing 0.

Output Specification
For each test case print the minimum amount of work units needed so that every inhabitant has his demand fulfilled. You may assume that this number fits into a signed 64-bit integer (in C/C++ you can use the data type "long long", in JAVA the data type "long").
Sample Input
5
5 -4 1 -3 1
6
-1000 -1000 -1000 1000 1000 1000
0
Sample Output
9
9000
解决方案:可先把最左边的问题解决了,让其归0,依次寻找左边第一个不为0的,将其解决。这个方法速度超级慢,有一个更快的方法,这里就不说了,人家的飞机速度,我的步行。
代码:
#include<iostream>
#include<cstdio>
#define MMAX 100003
using namespace std;
int num[MMAX];
int n;
int main(){

    while(~scanf("%d",&n)&&n){
      for(int i=0;i<n;i++){
        scanf("%d",&num[i]);
       }
       long long sum=0;
      for(int i=0;i<n;i++){
        if(num[i]>0){
            for(int j=i+1;j<n;j++){
             if(num[j]<0){
                if(num[i]+num[j]>0){
                    sum+=(i-j)*num[j];
                    num[i]+=num[j];
                    num[j]=0;


                }
                else {
                    num[j]+=num[i];
                    sum+=(j-i)*num[i];
                    num[i]=0;break;
                }
             }
            }
        }
        else if(num[i]<0){
            for(int j=i+1;j<n;j++){
                if(num[j]>0){
                if(num[i]+num[j]>0){
                    sum+=(i-j)*num[i];
                    num[j]+=num[i];
                    num[i]=0;
                    break;

                }
                else {
                    num[i]+=num[j];
                    sum+=(j-i)*num[j];
                    num[j]=0;
                }
             }

            }

        }
      }
      cout<<sum<<endl;
    }






    return 0;}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值