Time Limit: 3000MS | Memory Limit: Unknown | 64bit IO Format: %lld & %llu |
Description
The Lottery
The Lottery |
The Sports Association of Bangladesh is in great problem with their latest lottery 'Jodi laiga Jai'. There are so many participants this time that they cannot manage all the numbers. In an urgent meeting they have decided that they will ignore some numbers. But how they will choose those unlucky numbers!! Mr. NondoDulal who is very interested about historic problems proposed a scheme to get free from this problem.
You may be interested to know how he has got this scheme. Recently he has read the Joseph's problem.
The Problem
There are N tickets which are numbered from 1 to N. Mr. Nondo will choose M random numbers and then he will select those numbers which is divisible by at least one of those M numbers. The numbers which are not divisible by any of those M numbers will be considered for the lottery.As you know each number is divisible by 1. So Mr. Nondo will never select 1 as one of those M numbers. Now given N,M and M random numbers, you have to find out the number of tickets which will be considered for the lottery.
The Input
Each input set starts with two Integers N (10<=N<2^31) and M (1<=M<=15). The next line will contain M positive integers each of which is not greater than N. Input is terminated by EOF.
The Output
Just print in a line out of N tickets how many will be considered for the lottery.
Sample Input
10 2 2 3 20 2 2 4
Sample Output
3 10
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<vector>
#include<cstring>
#include<algorithm>
#define MMAX 1000000
using namespace std;
long long a[16];
bool vis[MMAX];
long long gcd(long long x,long long y){
if(x<y) swap(x,y);
if(y==0) return x;
else gcd(y,x%y);
}///辗转相除法
long long lcm(long long x,long long y){
return x*y/(gcd(x,y));
}
int main()
{
long long N,M;
while(~scanf("%lld%lld",&N,&M))
{
for(int k=0; k<M; k++)
{
scanf("%lld",&a[k]);
}
long long v=N,s,ans=N,cnt;
for(int i=1; i<(1<<M); i++)
{
s=1,cnt=0,v=N;
long long pre;
for(int j=0; j<M; j++)
{
if(i&(1<<j))
{
if(cnt==0){pre=a[j];}
else pre=lcm(a[j],pre);
cnt++;
if(pre>N) break;///这个可以达到增加效率的作用
///既然最小公倍数都大于N了那么,也没必要再乘上其它数了,由于这里,我tle了
}
}
if(pre>N) continue;///增加效率,
v/=pre;
if(cnt%2==0) ans+=v;
else ans-=v;
}
cout<<ans<<endl;
}
return 0;
}