Cookie Choice+ZOJ+01背包之终级背包

Cookie Choice

Time Limit: 2 Seconds       Memory Limit: 32768 KB

MM enjoyed cookies very much. On Saint Valentine's Day, when she stepped into a big cookie store again, she wouldn't leave unless DD spent all his money in pocket!

There are N kinds of cookies, labeled from 1 to N, and all can be bought without any restriction by the store. But actually, for some kinds of cookies, MM wanted to buy one piece at most, and for some kinds of cookies, MM wanted to buy Ki pieces at most, and for some other kinds of cookies, there didn't exist an upper bound that MM wanted to buy.

There is another requirement from MM: there are some groups of cookies, MM considered their tastes similar, so she wanted to buy at most one kind of cookies in each group. A kind of cookie wouldn't appear in more than one group.

For the ith kind of cookies, MM has an "enjoyable value" Ei, if DD bought Ai pieces of this kind for her, and Ai didn't exceed her upper bound, MM get EiAi of enjoyable value. After buying cookies, MM's total enjoyable value will be the sum of EiAi.

But actually, poor DD had only D dollars, and the price for the ith kind of cookies is Pi dollars per piece. DD must spend all his D dollars to buy cookies, to meet requirements about amount and taste from MM, and to make MM's enjoyable value as high as possible. What's more, as you know, a legal plan's enjoyable value must be non-negative.

Input

There are multiple test cases. Each test case consists of three parts.

The first part is one line with two integers N and D.

The second part has N lines, line i consists of three integers KiEi and Pi. If Ki equals to 0, it means for ith kind of cookies, there didn't exist an upper bound that MM wanted to buy, otherwise Ki is the upper bound for ith kind of cookies.

The third part describes the groups. A non-negative integer G represents the number of groups, and then G lines, each line consists of some integers represents labels of kinds of cookies in this group.

One blank line between test cases.

Output

If the proper and optimal plan exists, output the maximal total enjoyable value ΣEiAi, otherwise output "i'm sorry...".

Output one line per text case.

Data Restriction

1 <=  N  <= 1024, 0 <=  D  <= 1024.

0 <=  Ki  <= 1024, -1024 <=  Ei  <= 1024, 0 <  Pi  <=  D .

0 <=  G  <= 8.

All numbers referred are integers.

Number of test cases is no more than 80.

Sample Input

2 1024
0 1 3
0 0 1
0

10 1023
1 1 1
1 1 2
1 1 4
1 1 8
1 1 16
1 1 32
1 1 64
1 1 128
3 -1 256
1 1 512
1
9 10

10 1023
1 1 1
1 1 2
1 1 4
1 1 8
1 1 16
1 1 32
1 1 64
1 1 128
1 1 256
1 1 512
1
9 10

Sample Output

341
5
i'm sorry...
解决方案:求解是可分两部分,一个是分了组的,一个是没分组,没分组的之间按混合型背包问题来解,分好组的先在组内解出最优解集,然后把这两类的结果合并求出总的最优解。
code:
<pre name="code" class="cpp">#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
#define MMAX 2048
#define inf -0x3f3f3f3f
using namespace std;
int n,d,g;
struct node
{
    int k,e,p;
} candy[MMAX*10];
int belong[MMAX*10];
int dp[20408],temp[20408],w[10][20408];
void Clear(int len,int f[])
{
    for(int i=0; i<=len; i++)
    {
        f[i]=inf;
    }
    f[0]=0;
}
void zeroone(int f[],int i,int k)
{
    for(int v=d; v>=candy[i].p*k; v--)
        f[v]=max(f[v],f[v-candy[i].p*k]+candy[i].e*k);
}///01背包问题的求解
void complete(int f[],int i)
{
    for(int v=candy[i].p; v<=d; v++)
    {
        f[v]=max(f[v],f[v-candy[i].p]+candy[i].e);
    }
}///完全背包问题的求解
int main()
{
    while(~scanf("%d%d",&n,&d))
    {

        for(int i=1; i<=n; i++)
        {
            scanf("%d%d%d",&candy[i].k,&candy[i].e,&candy[i].p);
        }
        memset(belong,-1,sizeof(belong));
        scanf("%d",&g);
        getchar();
        for(int i=0; i<g; i++)
        {
            int a;
            char s;
            while(1)
            {
                scanf("%d%c",&a,&s);
                belong[a]=i;
                if(s=='\n') break;
            }

        }
        Clear(d+1,dp);
        Clear(d+1,temp);
        for(int i=0; i<g; i++)
            Clear(d+1,w[i]);
        for(int i=1; i<=n; i++)
        {
            if(belong[i]!=-1) Clear(d+1,temp);
            if(candy[i].k==0||candy[i].k*candy[i].p>=d)
            {
                complete(belong[i]!=-1?temp:dp,i);
            }
            else
            {
                int k=1;
                int cnt=candy[i].k;
                while(1)
                {
                    cnt-=k;
                    if(cnt<0)
                    {
                        cnt+=k;
                        break;
                    }
                    zeroone(belong[i]!=-1?temp:dp,i,k);
                    k*=2;
                }
                zeroone(belong[i]!=-1?temp:dp,i,cnt);
            }
            if(belong[i]!=-1)
                for(int j=0; j<=d; j++)
                w[belong[i]][j]=max(w[belong[i]][j],temp[j]);///由于组内成员为互斥的,所以必须只能选一类
        }
        for(int i=0; i<g; i++)
        {
            for(int j=d; j>=0; j--)
            {
                for(int s=0; s<=j; s++)
                {
                    dp[j]=max(dp[j],dp[j-s]+w[i][s]);
                }
            }
        }///将w的结果合并到dp
        if(dp[d]<0)
        {
            printf("i'm sorry...\n");
        }
        else
            printf("%d\n",dp[d]);
    }
    return 0;
}



                
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
资源包主要包含以下内容: ASP项目源码:每个资源包中都包含完整的ASP项目源码,这些源码采用了经典的ASP技术开发,结构清晰、注释详细,帮助用户轻松理解整个项目的逻辑和实现方式。通过这些源码,用户可以学习到ASP的基本语法、服务器端脚本编写方法、数据库操作、用户权限管理等关键技术。 数据库设计文件:为了方便用户更好地理解系统的后台逻辑,每个项目中都附带了完整的数据库设计文件。这些文件通常包括数据库结构图、数据表设计文档,以及示例数据SQL脚本。用户可以通过这些文件快速搭建项目所需的数据库环境,并了解各个数据表之间的关系和作用。 详细的开发文档:每个资源包都附有详细的开发文档,文档内容包括项目背景介绍、功能模块说明、系统流程图、用户界面设计以及关键代码解析等。这些文档为用户提供了深入的学习材料,使得即便是从零开始的开发者也能逐步掌握项目开发的全过程。 项目演示与使用指南:为帮助用户更好地理解和使用这些ASP项目,每个资源包中都包含项目的演示文件和使用指南。演示文件通常以视频或图文形式展示项目的主要功能和操作流程,使用指南则详细说明了如何配置开发环境、部署项目以及常见问题的解决方法。 毕业设计参考:对于正在准备毕业设计的学生来说,这些资源包是绝佳的参考材料。每个项目不仅功能完善、结构清晰,还符合常见的毕业设计要求和标准。通过这些项目,学生可以学习到如何从零开始构建一个完整的Web系统,并积累丰富的项目经验。
资源包主要包含以下内容: ASP项目源码:每个资源包中都包含完整的ASP项目源码,这些源码采用了经典的ASP技术开发,结构清晰、注释详细,帮助用户轻松理解整个项目的逻辑和实现方式。通过这些源码,用户可以学习到ASP的基本语法、服务器端脚本编写方法、数据库操作、用户权限管理等关键技术。 数据库设计文件:为了方便用户更好地理解系统的后台逻辑,每个项目中都附带了完整的数据库设计文件。这些文件通常包括数据库结构图、数据表设计文档,以及示例数据SQL脚本。用户可以通过这些文件快速搭建项目所需的数据库环境,并了解各个数据表之间的关系和作用。 详细的开发文档:每个资源包都附有详细的开发文档,文档内容包括项目背景介绍、功能模块说明、系统流程图、用户界面设计以及关键代码解析等。这些文档为用户提供了深入的学习材料,使得即便是从零开始的开发者也能逐步掌握项目开发的全过程。 项目演示与使用指南:为帮助用户更好地理解和使用这些ASP项目,每个资源包中都包含项目的演示文件和使用指南。演示文件通常以视频或图文形式展示项目的主要功能和操作流程,使用指南则详细说明了如何配置开发环境、部署项目以及常见问题的解决方法。 毕业设计参考:对于正在准备毕业设计的学生来说,这些资源包是绝佳的参考材料。每个项目不仅功能完善、结构清晰,还符合常见的毕业设计要求和标准。通过这些项目,学生可以学习到如何从零开始构建一个完整的Web系统,并积累丰富的项目经验。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值