Cookie Choice+ZOJ+01背包之终级背包

Cookie Choice

Time Limit: 2 Seconds       Memory Limit: 32768 KB

MM enjoyed cookies very much. On Saint Valentine's Day, when she stepped into a big cookie store again, she wouldn't leave unless DD spent all his money in pocket!

There are N kinds of cookies, labeled from 1 to N, and all can be bought without any restriction by the store. But actually, for some kinds of cookies, MM wanted to buy one piece at most, and for some kinds of cookies, MM wanted to buy Ki pieces at most, and for some other kinds of cookies, there didn't exist an upper bound that MM wanted to buy.

There is another requirement from MM: there are some groups of cookies, MM considered their tastes similar, so she wanted to buy at most one kind of cookies in each group. A kind of cookie wouldn't appear in more than one group.

For the ith kind of cookies, MM has an "enjoyable value" Ei, if DD bought Ai pieces of this kind for her, and Ai didn't exceed her upper bound, MM get EiAi of enjoyable value. After buying cookies, MM's total enjoyable value will be the sum of EiAi.

But actually, poor DD had only D dollars, and the price for the ith kind of cookies is Pi dollars per piece. DD must spend all his D dollars to buy cookies, to meet requirements about amount and taste from MM, and to make MM's enjoyable value as high as possible. What's more, as you know, a legal plan's enjoyable value must be non-negative.

Input

There are multiple test cases. Each test case consists of three parts.

The first part is one line with two integers N and D.

The second part has N lines, line i consists of three integers KiEi and Pi. If Ki equals to 0, it means for ith kind of cookies, there didn't exist an upper bound that MM wanted to buy, otherwise Ki is the upper bound for ith kind of cookies.

The third part describes the groups. A non-negative integer G represents the number of groups, and then G lines, each line consists of some integers represents labels of kinds of cookies in this group.

One blank line between test cases.

Output

If the proper and optimal plan exists, output the maximal total enjoyable value ΣEiAi, otherwise output "i'm sorry...".

Output one line per text case.

Data Restriction

1 <=  N  <= 1024, 0 <=  D  <= 1024.

0 <=  Ki  <= 1024, -1024 <=  Ei  <= 1024, 0 <  Pi  <=  D .

0 <=  G  <= 8.

All numbers referred are integers.

Number of test cases is no more than 80.

Sample Input

2 1024
0 1 3
0 0 1
0

10 1023
1 1 1
1 1 2
1 1 4
1 1 8
1 1 16
1 1 32
1 1 64
1 1 128
3 -1 256
1 1 512
1
9 10

10 1023
1 1 1
1 1 2
1 1 4
1 1 8
1 1 16
1 1 32
1 1 64
1 1 128
1 1 256
1 1 512
1
9 10

Sample Output

341
5
i'm sorry...
解决方案:求解是可分两部分,一个是分了组的,一个是没分组,没分组的之间按混合型背包问题来解,分好组的先在组内解出最优解集,然后把这两类的结果合并求出总的最优解。
code:
<pre name="code" class="cpp">#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
#define MMAX 2048
#define inf -0x3f3f3f3f
using namespace std;
int n,d,g;
struct node
{
    int k,e,p;
} candy[MMAX*10];
int belong[MMAX*10];
int dp[20408],temp[20408],w[10][20408];
void Clear(int len,int f[])
{
    for(int i=0; i<=len; i++)
    {
        f[i]=inf;
    }
    f[0]=0;
}
void zeroone(int f[],int i,int k)
{
    for(int v=d; v>=candy[i].p*k; v--)
        f[v]=max(f[v],f[v-candy[i].p*k]+candy[i].e*k);
}///01背包问题的求解
void complete(int f[],int i)
{
    for(int v=candy[i].p; v<=d; v++)
    {
        f[v]=max(f[v],f[v-candy[i].p]+candy[i].e);
    }
}///完全背包问题的求解
int main()
{
    while(~scanf("%d%d",&n,&d))
    {

        for(int i=1; i<=n; i++)
        {
            scanf("%d%d%d",&candy[i].k,&candy[i].e,&candy[i].p);
        }
        memset(belong,-1,sizeof(belong));
        scanf("%d",&g);
        getchar();
        for(int i=0; i<g; i++)
        {
            int a;
            char s;
            while(1)
            {
                scanf("%d%c",&a,&s);
                belong[a]=i;
                if(s=='\n') break;
            }

        }
        Clear(d+1,dp);
        Clear(d+1,temp);
        for(int i=0; i<g; i++)
            Clear(d+1,w[i]);
        for(int i=1; i<=n; i++)
        {
            if(belong[i]!=-1) Clear(d+1,temp);
            if(candy[i].k==0||candy[i].k*candy[i].p>=d)
            {
                complete(belong[i]!=-1?temp:dp,i);
            }
            else
            {
                int k=1;
                int cnt=candy[i].k;
                while(1)
                {
                    cnt-=k;
                    if(cnt<0)
                    {
                        cnt+=k;
                        break;
                    }
                    zeroone(belong[i]!=-1?temp:dp,i,k);
                    k*=2;
                }
                zeroone(belong[i]!=-1?temp:dp,i,cnt);
            }
            if(belong[i]!=-1)
                for(int j=0; j<=d; j++)
                w[belong[i]][j]=max(w[belong[i]][j],temp[j]);///由于组内成员为互斥的,所以必须只能选一类
        }
        for(int i=0; i<g; i++)
        {
            for(int j=d; j>=0; j--)
            {
                for(int s=0; s<=j; s++)
                {
                    dp[j]=max(dp[j],dp[j-s]+w[i][s]);
                }
            }
        }///将w的结果合并到dp
        if(dp[d]<0)
        {
            printf("i'm sorry...\n");
        }
        else
            printf("%d\n",dp[d]);
    }
    return 0;
}



                
深度学习是机器学习的一个子领域,它基于人工神经网络的研究,特别是利用多层次的神经网络来进行学习和模式识别。深度学习模型能够学习数据的高层次特征,这些特征对于图像和语音识别、自然语言处理、医学图像分析等应用至关重要。以下是深度学习的一些关键概念和组成部分: 1. **神经网络(Neural Networks)**:深度学习的基础是人工神经网络,它是由多个层组成的网络结构,包括输入层、隐藏层和输出层。每个层由多个神经元组成,神经元之间通过权重连接。 2. **前馈神经网络(Feedforward Neural Networks)**:这是最常见的神经网络类型,信息从输入层流向隐藏层,最终到达输出层。 3. **卷积神经网络(Convolutional Neural Networks, CNNs)**:这种网络特别适合处理具有网格结构的数据,如图像。它们使用卷积层来提取图像的特征。 4. **循环神经网络(Recurrent Neural Networks, RNNs)**:这种网络能够处理序列数据,如时间序列或自然语言,因为它们具有记忆功能,能够捕捉数据中的时间依赖性。 5. **长短期记忆网络(Long Short-Term Memory, LSTM)**:LSTM 是一种特殊的 RNN,它能够学习长期依赖关系,非常适合复杂的序列预测任务。 6. **生成对抗网络(Generative Adversarial Networks, GANs)**:由两个网络组成,一个生成器和一个判别器,它们相互竞争,生成器生成数据,判别器评估数据的真实性。 7. **深度学习框架**:如 TensorFlow、Keras、PyTorch 等,这些框架提供了构建、训练和部署深度学习模型的工具和库。 8. **激活函数(Activation Functions)**:如 ReLU、Sigmoid、Tanh 等,它们在神经网络中用于添加非线性,使得网络能够学习复杂的函数。 9. **损失函数(Loss Functions)**:用于评估模型的预测与真实值之间的差异,常见的损失函数包括均方误差(MSE)、交叉熵(Cross-Entropy)等。 10. **优化算法(Optimization Algorithms)**:如梯度下降(Gradient Descent)、随机梯度下降(SGD)、Adam 等,用于更新网络权重,以最小化损失函数。 11. **正则化(Regularization)**:技术如 Dropout、L1/L2 正则化等,用于防止模型过拟合。 12. **迁移学习(Transfer Learning)**:利用在一个任务上训练好的模型来提高另一个相关任务的性能。 深度学习在许多领域都取得了显著的成就,但它也面临着一些挑战,如对大量数据的依赖、模型的解释性差、计算资源消耗大等。研究人员正在不断探索新的方法来解决这些问题。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值