Black Box+POJ+treap树模板

Black Box
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 7437 Accepted: 3051

Description

Our Black Box represents a primitive database. It can save an integer array and has a special i variable. At the initial moment Black Box is empty and i equals 0. This Black Box processes a sequence of commands (transactions). There are two types of transactions: 

ADD (x): put element x into Black Box; 
GET: increase i by 1 and give an i-minimum out of all integers containing in the Black Box. Keep in mind that i-minimum is a number located at i-th place after Black Box elements sorting by non- descending. 

Let us examine a possible sequence of 11 transactions: 

Example 1 
N Transaction i Black Box contents after transaction Answer 

      (elements are arranged by non-descending)   

1 ADD(3)      0 3   

2 GET         1 3                                    3 

3 ADD(1)      1 1, 3   

4 GET         2 1, 3                                 3 

5 ADD(-4)     2 -4, 1, 3   

6 ADD(2)      2 -4, 1, 2, 3   

7 ADD(8)      2 -4, 1, 2, 3, 8   

8 ADD(-1000)  2 -1000, -4, 1, 2, 3, 8   

9 GET         3 -1000, -4, 1, 2, 3, 8                1 

10 GET        4 -1000, -4, 1, 2, 3, 8                2 

11 ADD(2)     4 -1000, -4, 1, 2, 2, 3, 8   

It is required to work out an efficient algorithm which treats a given sequence of transactions. The maximum number of ADD and GET transactions: 30000 of each type. 


Let us describe the sequence of transactions by two integer arrays: 


1. A(1), A(2), ..., A(M): a sequence of elements which are being included into Black Box. A values are integers not exceeding 2 000 000 000 by their absolute value, M <= 30000. For the Example we have A=(3, 1, -4, 2, 8, -1000, 2). 

2. u(1), u(2), ..., u(N): a sequence setting a number of elements which are being included into Black Box at the moment of first, second, ... and N-transaction GET. For the Example we have u=(1, 2, 6, 6). 

The Black Box algorithm supposes that natural number sequence u(1), u(2), ..., u(N) is sorted in non-descending order, N <= M and for each p (1 <= p <= N) an inequality p <= u(p) <= M is valid. It follows from the fact that for the p-element of our u sequence we perform a GET transaction giving p-minimum number from our A(1), A(2), ..., A(u(p)) sequence. 


Input

Input contains (in given order): M, N, A(1), A(2), ..., A(M), u(1), u(2), ..., u(N). All numbers are divided by spaces and (or) carriage return characters.

Output

Write to the output Black Box answers sequence for a given sequence of transactions, one number each line.

Sample Input

7 4
3 1 -4 2 8 -1000 2
1 2 6 6

Sample Output

3
3
1
2
解决方案:动态的添加数据,动态求第i大的数字。直接裸treap。
code:
<pre name="code" class="cpp">#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
using namespace std;
struct node
{
    node *ch[2];
    int r;///优先级
    int v;///节点值
    int s;
    int cmp(int x)const
    {
        if(x==v) return -1;
        else return x<v?0:1;
    }
    void maintain()
    {
        s=1;
        if(ch[0]!=NULL) s+=ch[0]->s;
        if(ch[1]!=NULL) s+=ch[1]->s;
    }///统计rank
};
void rotate(node* & rt,int d)
{
    node *k=rt->ch[d^1];
    rt->ch[d^1]=k->ch[d];
    k->ch[d]=rt;
    rt->maintain();
    k->maintain();///必须先更新rt再更新k
    rt=k;
}///left rotate and right rotate

void insert(node * & rt,int x)
{
    if(rt==NULL)
    {
        rt=new node();
        rt->ch[0]=rt->ch[1]=NULL;
        rt->v=x;
        rt->s=1;
        rt->r=rand();///建立新的节点,插入数字
    }
    else
    {
        int d=(x<=rt->v?0:1);
        insert(rt->ch[d],x);///选择合适的位置插入
        if((rt->ch[d]->r)>rt->r)
            rotate(rt,d^1);///左孩子优先级大右旋,右孩纸优先级大左旋
    }
    rt->maintain();///儿子节点发生改变,其父节点也要更新
}
int kth(node *rt,int k)
{
    if(rt==NULL||k<=0||k>rt->s) return 0;
    int s=(rt->ch[0]==NULL?0:rt->ch[0]->s);
    if(s+1==k) return rt->v;
    else if(s>=k) return kth(rt->ch[0],k);
    else return kth(rt->ch[1],k-s-1);

}///查询第k大的数字
int v[30004];
int main()
{
    int n,k;
    while(~scanf("%d%d",&n,&k))
    {
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&v[i]);
        }
        node *root=NULL;
        int now=1;
        for(int i=1; i<=k; i++)
        {
            int x;
            scanf("%d",&x);
            for(; now<=x; now++)
                insert(root,v[now]);
            printf("%d\n",kth(root,i));
        }

    }
    return 0;
}




                
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值