Always on the run+uva+DAG图上的dp

Time Limit: 3000MS Memory Limit: Unknown 64bit IO Format: %lld & %llu


Description

Download as PDF


  Always on the run 

Screeching tires. Searching lights. Wailing sirens. Police cars everywhere. Trisha Quickfinger did it again! Stealing the `Mona Lisa' had been more difficult than planned, but being the world's best art thief means expecting the unexpected. So here she is, the wrapped frame tucked firmly under her arm, running to catch the northbound metro to Charles-de-Gaulle airport.

But even more important than actually stealing the painting is to shake off the police that will soon be following her. Trisha's plan is simple: for several days she will be flying from one city to another, making one flight per day. When she is reasonably sure that the police has lost her trail, she will fly to Atlanta and meet her `customer' (known only as Mr. P.) to deliver the painting.

Her plan is complicated by the fact that nowadays, even when you are stealing expensive art, you have to watch your spending budget. Trisha therefore wants to spend the least money possible on her escape flights. This is not easy, since airlines prices and flight availability vary from day to day. The price and availability of an airline connection depends on the two cities involved and the day of travel. Every pair of cities has a `flight schedule' which repeats every few days. The length of the period may be different for each pair of cities and for each direction.

Although Trisha is a good at stealing paintings, she easily gets confused when booking airline flights. This is where you come in.

Input 

The input file contains the descriptions of several scenarios in which Trisha tries to escape. Every description starts with a line containing two integers  n  and  k n  is the number of cities through which Trisha's escape may take her, and  k  is the number of flights she will take. The cities are numbered $1, 2, \dots, n$, where 1 is Paris, her starting point, and  n  is Atlanta, her final destination. The numbers will satisfy $2 \leŸ n \leŸ 10$ and $1 \leŸ k \leŸ 1000$.

Next you are given n(n - 1) flight schedules, one per line, describing the connection between every possible pair of cities. The first n - 1 flight schedules correspond to the flights from city 1 to all other cities ( $2, 3, \dots, n$), the next n - 1 lines to those from city 2 to all others ( $1, 3, 4, \dots, n$), and so on.

The description of the flight schedule itself starts with an integer d, the length of the period in days, with $1 \leŸ d \leŸ 30$. Following this are d non-negative integers, representing the cost of the flight between the two cities on days $1, 2, \dots, d$. A cost of 0 means that there is no flight between the two cities on that day.

So, for example, the flight schedule ``3 75 0 80'' means that on the first day the flight costs 75, on the second day there is no flight, on the third day it costs 80, and then the cycle repeats: on the fourth day the flight costs 75, there is no flight on the fifth day, etc.

The input is terminated by a scenario having n = k = 0.

Output 

For each scenario in the input, first output the number of the scenario, as shown in the sample output. If it is possible for Trisha to travel  k  days, starting in city 1, each day flying to a different city than the day before, and finally (after  k  days) arriving in city  n , then print ``  The best flight costs  x .'', where  x  is the least amount that the  k  flights can cost.

If it is not possible to travel in such a way, print ``No flight possible.''.

Print a blank line after each scenario.

Sample Input 

3 6
2 130 150
3 75 0 80
7 120 110 0 100 110 120 0
4 60 70 60 50
3 0 135 140
2 70 80
2 3
2 0 70
1 80
0 0

Sample Output 

Scenario #1
The best flight costs 460.

Scenario #2
No flight possible.
 
  
 
  
解决方案:dp[i][j],表示第i天到j城市所需的最小花费, dp[i][j]=min(dp[i][j],dp[i-1][N[v].to]+N[v].sche[(i-1)%N[v].v]);
N[v].to表示出发点,N[v].sche[(i-1)%N[v].v]表示从出发点到j点的花费。边界条件为dp[0][1]=0;由于要用到取余,天数从0开始。
code:
#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn=120;
const int maxday=1005;
const int inf=0x3f3f3f3f;
struct node
{
    int v;
    int sche[40];
    int next;
    int to;
} N[maxn];
int n,k,top;
int head[maxn];
void add(int from,int to,int v)
{

    for(int i=0; i<v; i++)
    {
        scanf("%d",&N[top].sche[i]);
    }
    N[top].v=v;
    N[top].to=to;
    N[top].next=head[from];
    head[from]=top++;
}
int dp[maxday][maxn];
int main()
{
    int kkk=0;
    while(~scanf("%d%d",&n,&k)&&(k+n))
    {
        top=0;

        memset(head,-1,sizeof(head));
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=n; j++)
            {
                if(i!=j)
                {   int v;
                    scanf("%d",&v);
                    add(j,i,v);
                }
            }
        }
        memset(dp,0x3f,sizeof(dp));
        dp[0][1]=0;
        for(int i=1; i<=k; i++)
        {
            for(int j=1; j<=n; j++)
            {

                for(int v=head[j]; v!=-1; v=N[v].next)
                {
                    if(N[v].sche[(i-1)%N[v].v]!=0&&dp[i-1][N[v].to]!=inf)
                    {
                        dp[i][j]=min(dp[i][j],dp[i-1][N[v].to]+N[v].sche[(i-1)%N[v].v]);
                    }
                }

            }
        }
        printf("Scenario #%d\n",++kkk);
        if(dp[k][n]!=inf)
        {
            printf("The best flight costs %d.\n",dp[k][n]);
        }
        else
        {
            printf("No flight possible.\n");
        }
        printf("\n");
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值