poj1258


Language:
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 43749 Accepted: 17898

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course. 
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 
The distance between any two farms will not exceed 100,000. 

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28

Source




/*
类似题目:hdu1233
1).输入:一个加权连通图,其中顶点集合为V,边集合为E;
2).初始化:Vnew = {x},其中x为集合V中的任一节点(起始点),Enew = {},为空;
3).重复下列操作,直到Vnew = V:
a.在集合E中选取权值最小的边<u, v>,其中u为集合Vnew中的元素,而v不在Vnew集合当中,
并且v∈V(如果存在有多条满足前述条件即具有相同权值的边,则可任意选取其中之一);
b.将v加入集合Vnew中,将<u, v>边加入集合Enew中;
4).输出:使用集合Vnew和Enew来描述所得到的最小生成树。
 
prim算法适合稠密图,其时间复杂度为O(n^2),其时间复杂度与边得数目无关,
而kruskal算法的时间复杂度为O(eloge)跟边的数目有关,适合稀疏图。
*/
#include<stdio.h>
#include<string.h>
#include<limits.h>
int n,map[102][102],vis[102],low[102];
int prime()
{
memset(vis,0,sizeof vis);
int ans,min,pos;
ans=0;
pos=1;
vis[1]=1;
for(int i=2;i<=n;i++)
   low[i]=map[pos][i];
    for(int i=1;i<n;i++)
    {
    min=INT_MAX;
    for(int j=2;j<=n;j++)
       if(!vis[j]&&min>low[j])
       {
        min=low[j];
        pos=j;
       }
   vis[pos]=1;
   ans+=min;
   for(int j=2;j<=n;j++)
       if(!vis[j]&&low[j]>map[pos][j])
              low[j]=map[pos][j];
    }
    return ans;
}
int main()
{
    while(scanf("%d",&n)!=EOF)
{
memset(map,-1,sizeof map);
for(int i=1;i<=n;++i)
  for(int j=1;j<=n;++j)
               scanf("%d",&map[i][j]);
        printf("%d\n",prime());   
}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值