Sicily 7966. Another Dice Game

7966. Another Dice Game

Constraints

Time Limit: 1 secs, Memory Limit: 256 MB , Special Judge

Description

In the game Pickomino one has to throw 8 dice to reach at least a certain target score. The rules are as follows:

  • The dice contain the values 1, 2, 3, 4, 5 and worm. The dice are fair, so all outcomes are equally likely.
  • The game is started by throwing all dice.
  • After a throw, the player must pick one of the six possible values and put all dice with this value aside. There must be at least one die with this value.
  • After putting some dice aside, the player may choose to either throw the remaining dice again or stop. The player may only stop after at least one worm has been put aside.
  • Each possible value may only be chosen once during the game.
  • When the player stops, his total score is the sum of the values of the dice that were put aside. A worm is worth 5 points.
  • The player can get stuck by throwing only values that were already put aside, by having put all dice aside but not having a worm or by not having reached the target score.
  • If the player is stuck he scores 0 points and the game is ended.

Jan is playing Pickomino and wants to score at least n points. When Jan uses an optimal strategy, what is the probability that he reaches this target?

Input

On the first line one positive number: the number of test cases, at most 100. After that per test case:

  • one line with the integer n (1 <= n <= 40): the target value.

Output

Per test case:

  • one line with a floating point number: the probability that you score at least n points when using an optimal strategy.

This number should be accurate up to 10-6 relative or absolute precision.

Sample Input

3
5
21
40

Sample Output

0.9934260978934218
0.8930267371507457
0.0001461079070016448

Hint

To reach 5 points it is enough to throw at least one worm. The optimal strategy in this case is therefore to stop as soon as you have a worm. If you did not throw a worm, you should put aside as few dice as possible to maximize the chance of throwing a worm in a later throw.

Problem Source

2013年每周一赛第五场暨校赛模拟赛III/BAPC 2012

// Problem#: 7966
// Submission#: 3593634
// The source code is licensed under Creative Commons Attribution-NonCommercial-ShareAlike 3.0 Unported License
// URI: http://creativecommons.org/licenses/by-nc-sa/3.0/
// All Copyright reserved by Informatic Lab of Sun Yat-sen University
// Solution to Another Dice Game
// Author: Thomas Beuman

// Time complexity: O((n * dice * 2^6) * bin(n+5,5) *    6   )
//                  O(     states      *   throws   * options)
// Memory: O(n * dice * 2^6)

// @EXPECTED_RESULTS@: CORRECT

// Solution method: DFS with memorization

#include <cstdio>
#include <algorithm>
#include <cmath>
#include <cstring>
using namespace std;

typedef double dbl; // Use long double for greater accuracy

dbl Prob[41][9][64];
bool Seen[41][9][64];
int Points[6] = {1,2,3,4,5,5};
int Factorial[9] = {1,1,2,6,24,120,720,5040,40320};

// Returns probability of reaching target, given number of dice and values not yet put aside
dbl prob (int target, int dice, int available)
{ if (target <= 0 && !(available & 32)) // Target reached and worm put aside
    return 1.0;
  if (dice == 0) // Failed
    return 0;
  if (target < 0) // Only a worm left to get
    target = 0;
  if (Seen[target][dice][available]) // Already calculated
    return Prob[target][dice][available];
  int Number[6];
  int i, perm;
  dbl best, p = 0;
  // Consider all possible outcomes of the throw
  // First possibility: all ones
  Number[0] = dice;
  for (i = 1; i < 6; i++)
    Number[i] = 0;
  while (true)
  { // Determine number of permutations (= weight factor)
    perm = Factorial[dice];
    for (i = 0; i < 6; i++)
      perm /= Factorial[Number[i]];
    // Look for best strategy: try all options
    best = 0;
    for (i = 0; i < 6; i++)
      if ((available & (1 << i)) && Number[i] > 0)
        best = max(best, prob(target - Number[i]*Points[i], dice - Number[i], available ^ (1 << i)));
    p += perm * best;
    // Next possible outcome
    for (i = 0; Number[i] == 0; i++); // Look for smallest value
    if (i == 5)
      break; // Done
    Number[i+1]++; // Increase value of one die with smallest value by one
    Number[0] = Number[i]-1; // Turn others into ones
    if (i > 0)
      Number[i] = 0;
  }
  Seen[target][dice][available] = true;
  return Prob[target][dice][available] = p / pow(6.0, dice);
}

int main()
{ int cases, casenr, n;
  scanf("%d\n", &cases);
  memset(Seen, false, sizeof(Seen));
  for (casenr = 1; casenr <= cases; casenr++)
  { scanf("%d", &n);
    printf("%.10lf\n", prob(n, 8, 63));
  }
  return 0;
}                                 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
资源包主要包含以下内容: ASP项目源码:每个资源包中都包含完整的ASP项目源码,这些源码采用了经典的ASP技术开发,结构清晰、注释详细,帮助用户轻松理解整个项目的逻辑和实现方式。通过这些源码,用户可以学习到ASP的基本语法、服务器端脚本编写方法、数据库操作、用户权限管理等关键技术。 数据库设计文件:为了方便用户更好地理解系统的后台逻辑,每个项目中都附带了完整的数据库设计文件。这些文件通常包括数据库结构图、数据表设计文档,以及示例数据SQL脚本。用户可以通过这些文件快速搭建项目所需的数据库环境,并了解各个数据表之间的关系和作用。 详细的开发文档:每个资源包都附有详细的开发文档,文档内容包括项目背景介绍、功能模块说明、系统流程图、用户界面设计以及关键代码解析等。这些文档为用户提供了深入的学习材料,使得即便是从零开始的开发者也能逐步掌握项目开发的全过程。 项目演示与使用指南:为帮助用户更好地理解和使用这些ASP项目,每个资源包中都包含项目的演示文件和使用指南。演示文件通常以视频或图文形式展示项目的主要功能和操作流程,使用指南则详细说明了如何配置开发环境、部署项目以及常见问题的解决方法。 毕业设计参考:对于正在准备毕业设计的学生来说,这些资源包是绝佳的参考材料。每个项目不仅功能完善、结构清晰,还符合常见的毕业设计要求和标准。通过这些项目,学生可以学习到如何从零开始构建一个完整的Web系统,并积累丰富的项目经验。
资源包主要包含以下内容: ASP项目源码:每个资源包中都包含完整的ASP项目源码,这些源码采用了经典的ASP技术开发,结构清晰、注释详细,帮助用户轻松理解整个项目的逻辑和实现方式。通过这些源码,用户可以学习到ASP的基本语法、服务器端脚本编写方法、数据库操作、用户权限管理等关键技术。 数据库设计文件:为了方便用户更好地理解系统的后台逻辑,每个项目中都附带了完整的数据库设计文件。这些文件通常包括数据库结构图、数据表设计文档,以及示例数据SQL脚本。用户可以通过这些文件快速搭建项目所需的数据库环境,并了解各个数据表之间的关系和作用。 详细的开发文档:每个资源包都附有详细的开发文档,文档内容包括项目背景介绍、功能模块说明、系统流程图、用户界面设计以及关键代码解析等。这些文档为用户提供了深入的学习材料,使得即便是从零开始的开发者也能逐步掌握项目开发的全过程。 项目演示与使用指南:为帮助用户更好地理解和使用这些ASP项目,每个资源包中都包含项目的演示文件和使用指南。演示文件通常以视频或图文形式展示项目的主要功能和操作流程,使用指南则详细说明了如何配置开发环境、部署项目以及常见问题的解决方法。 毕业设计参考:对于正在准备毕业设计的学生来说,这些资源包是绝佳的参考材料。每个项目不仅功能完善、结构清晰,还符合常见的毕业设计要求和标准。通过这些项目,学生可以学习到如何从零开始构建一个完整的Web系统,并积累丰富的项目经验。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值