Sicily 1895. Maze, amazing

1895. Maze, amazing

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

Let’s play maze game again! Maze problem is an old problem but here comes a challenge one. Max, an intelligent robot, is trapped in an N*M maze grid. He is located at a start position initially and aiming to find the exit of the maze. In the maze there are numbers of pillars which are set as obstacles. Max is energetic and not afraid of strolling in the maze at all. But he dislikes turning round in the maze all through. “Turning left or right several times keeps me uncomfortable and confused! It makes me feel sick and unconfident to run out of this maze!” Max said.
Given the cost of turning left and right of Max, the description of the maze grid, the start position and destination, you are going to give your hand to Max by calculating the minimum cost of turning round (no matter left or right) to get to the exit from start position.
Note: Max can just perform three operations at one time: go front, turn left, and turn right. Initially Max stands at the start point and you should decide in which direction he starts the first step in order to minimize the total dislike of Max. 

Input

 Input may consist of several test data sets. For each data set, it can be format as below:
First comes two integers in one line separating with one space: l(1 <= l <= 100) representing the cost of turning left of Max, r(1 <= r <= 100) representing the cost of turning right of Max.
Then six integers follows in next coming line separating with one space: r1 (1 <= r1 <= 100) representing the number of rows of the maze grid, c (1 <= c <= 100) representing the number of columns of the maze grid, sx (1 <= sx <= r1) representing the row position of the start position of Max, sy (1 <= sy <= c) representing the column position of the start position of Max, ex (1 <= ex <= r1) representing the row position of the exit of the maze, ey (1 <= ey <= c) representing the column position of the exit of the maze.
Finally comes rl row(s) with c character(s) in each row. This part represents the maze data part and all character(s) can only be two types: ‘*’ representing a pillar of the maze and ‘.’ representing an empty grid cell that Max can stand on. Position of cell in the upperleft corner of the grid is (1, 1).
Input is ended with l = r = 0.
Note: Max can’t go outside the range of the row and column of the maze, either go pass the pillar. You can assume the input is legal that means there is no pillar in the start position and exit of the maze.

Output

Output one integer in one line representing the minimum cost of turning to get to the exit if there is one way to get there, or output -1 in one line if it is impossible for Max to get to the destination.

Sample Input

1 2
1 4 1 1 1 4
....
1 2 
1 4 1 1 1 4
..*.
1 2
2 4 2 1 2 4
....
..*.
1 2
3 4 2 1 2 4
*...
..*.
*...
0 0

Sample Output

0
-1
4

4

// Problem#: 1895
// Submission#: 3592777
// The source code is licensed under Creative Commons Attribution-NonCommercial-ShareAlike 3.0 Unported License
// URI: http://creativecommons.org/licenses/by-nc-sa/3.0/
// All Copyright reserved by Informatic Lab of Sun Yat-sen University
#include <stdio.h>
#include <vector>
#include <functional>
#include <algorithm>
using namespace std;

const int MAX_POINT = 105 * 105;
const int INF = 1000000000;

struct Node {
    int d, i, j;
    Node(int _d = 0, int _i = 0, int _j = 0) {
        d = _d;
        i = _i;
        j = _j;
    }
};

int dir[4][2] = {0, 1, 1, 0, 0, -1, -1, 0};
int n, w, h, l, r;
int si, sj, ei, ej;
int d[MAX_POINT][4];
bool G[105][105];
pair<int, Node> arr[4 * MAX_POINT];
int len;

void fix_up_min_heap(int i ) {
	int j = ( i - 1 ) / 2;	// parent index
	pair<int, Node> tmp = arr[i];
    while( j >= 0 && tmp.first < arr[j].first) {
		arr[i] = arr[j]; i = j; 
		if( j > 0 )
			j = ( j - 1 ) / 2;
		else
			break;
	}
	arr[i] = tmp;
}

void fix_down_min_heap(int i ) {
	int j = 2 * i + 1;
	pair<int, Node> tmp = arr[i];
	while( j < len )
	{
		if( j < len - 1 && arr[j + 1].first < arr[j].first) 
			++j;
		if( arr[j].first < tmp.first)
		{
			arr[i] = arr[j]; 
			i = j; 
			j = 2 * i + 1;
		}
		else
		{
			break;
		}
	}
	arr[i] = tmp;
}

void insert_min_heap(pair<int, Node> x) {
	//if( n == *len ) return -1;
	arr[len++] = x;
	fix_up_min_heap(len - 1);
}

void pop_min_heap() {
	// assert( *len > 0 );
	arr[0] = arr[--len];
	fix_down_min_heap(0);
}

inline bool isValid(int & i, int & j) {
    return 0 <= i && i < h && 0 <= j && j < w && G[i][j];
}

void Dijkstra() {
    len = 0;
    for (int i = 0; i < n; i++) d[i][0] = d[i][1] = d[i][2] = d[i][3] = INF;
    for (int i = 0; i < 4; i++) {
        d[si * w + sj][i] = 0;
        insert_min_heap(make_pair(0, Node(i, si, sj)));
    }
    while (len) {
        int now_c = arr[0].first;
        int now_i = arr[0].second.i;
        int now_j = arr[0].second.j;
        int now_d = arr[0].second.d;
        int s = now_i * w + now_j;
        int next_i, next_j, next_d, next_s;
        pop_min_heap();
        if (d[s][now_d] < now_c) continue;
        //1
        next_i = now_i + dir[now_d][0];
        next_j = now_j + dir[now_d][1];
        next_s = next_i * w + next_j;
        if (isValid(next_i, next_j) && d[next_s][now_d] > d[s][now_d]) {
            d[next_s][now_d] = d[s][now_d];
            insert_min_heap(make_pair(d[next_s][now_d], Node(now_d, next_i, next_j)));
        }
        //2 turn left
        next_d = (now_d + 3) % 4;
        next_i = now_i + dir[next_d][0];
        next_j = now_j + dir[next_d][1];
        next_s = next_i * w + next_j;
        if (isValid(next_i, next_j) && d[next_s][next_d] > d[s][now_d] + l) {
            d[next_s][next_d] = d[s][now_d] + l;
            insert_min_heap(make_pair(d[next_s][next_d], Node(next_d, next_i, next_j)));
        }
        //3 turn right
        next_d = (now_d + 1) % 4;
        next_i = now_i + dir[next_d][0];
        next_j = now_j + dir[next_d][1];
        next_s = next_i * w + next_j;
        if (isValid(next_i, next_j) && d[next_s][next_d] > d[s][now_d] + r) {
            d[next_s][next_d] = d[s][now_d] + r;
            insert_min_heap(make_pair(d[next_s][next_d], Node(next_d, next_i, next_j)));
        }
    }
}

int main() {
    while (scanf("%d%d", &l, &r) != EOF) {
        if (l == 0 && r == 0) break;
        scanf("%d%d%d%d%d%d", &h, &w, &si, &sj, &ei, &ej);
        n = w * h;
        si--, sj--, ei--, ej--;
        char temp[105];
        for (int i = 0; i < h; i++) {
            scanf("%s", temp);
            for (int j = 0; temp[j] != '\0'; j++) {
                if (temp[j] == '.') G[i][j] = true;
                else G[i][j] = false;
            }
        }
        Dijkstra();
        int ans = min(d[ei * w + ej][0], min(d[ei * w + ej][1], min(d[ei * w + ej][2], d[ei * w + ej][3])));
        printf("%d\n", ans == INF ? -1 : ans);
    }
    return 0;
}                                 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
智慧校园的建设目标是通过数据整合、全面共享,实现校园内教学、科研、管理、服务流程的数字化、信息化、智能化和多媒体化,以提高资源利用率和管理效率,确保校园安全。 智慧校园的建设思路包括构建统一支撑平台、建立完善管理体系、大数据辅助决策和建设校园智慧环境。通过云架构的数据中心与智慧的学习、办公环境,实现日常教学活动、资源建设情况、学业水平情况的全面统计和分析,为决策提供辅助。此外,智慧校园还涵盖了多媒体教学、智慧录播、电子图书馆、VR教室等多种教学模式,以及校园网络、智慧班牌、校园广播等教务管理功能,旨在提升教学品质和管理水平。 智慧校园的详细方案设计进一步细化了教学、教务、安防和运维等多个方面的应用。例如,在智慧教学领域,通过多媒体教学、智慧录播、电子图书馆等技术,实现教学资源的共享和教学模式的创新。在智慧教务方面,校园网络、考场监控、智慧班牌等系统为校园管理提供了便捷和高效。智慧安防系统包括视频监控、一键报警、阳光厨房等,确保校园安全。智慧运维则通过综合管理平台、设备管理、能效管理和资产管理,实现校园设施的智能化管理。 智慧校园的优势和价值体现在个性化互动的智慧教学、协同高效的校园管理、无处不在的校园学习、全面感知的校园环境和轻松便捷的校园生活等方面。通过智慧校园的建设,可以促进教育资源的均衡化,提高教育质量和管理效率,同时保障校园安全和提升师生的学习体验。 总之,智慧校园解决方案通过整合现代信息技术,如云计算、大数据、物联网和人工智能,为教育行业带来了革命性的变革。它不仅提高了教育的质量和效率,还为师生创造了一个更加安全、便捷和富有智慧的学习与生活环境。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值