Sicily 2679. Rooks

2679. Rooks

Constraints

Time Limit: 1 secs, Memory Limit: 256 MB

Description

Many mathematical problems on chessboard have been studied. The 8-queens problem, may be the most famous, is to place 8 queens on the chessboard so that they do not attack each other. This problem is probably as old as the chess game itself, and thus its origin is not known, but it is known that Gauss studied this problem.
The same sort of question about rooks can be asked. Two rooks are said to be attacking each other if they are placed in the same row or column of the chessboard. How many ways are there to place 8 non-attacking rooks on a chessboard? The answer is quit easy, and can be soled generally: on an n by n chessboard, the number of ways to place n non-attacking rooks is n! (The two ways of placing on 2-by-2 chessboard are shown in Figure 6.1.1.
 
R
 
 
 
R
 
R
 
R
 
Figure 6.1.1  two ways of placing on 2-by-2 chessboard
 
Since a n-by-n chessboard can also be considered to be a n+1 by n+1 grid, a path can be drawn along the grid line from the upper left corner to the lower right corner by going right or down at each turning.
A configuration of a chessboard is a placing of rooks with a path that all rooks are below the path (all three configurations of 2-by-2 chessboard are shown in Figure6.1.2).
 
R
 
 
R
 
 
 
R
 
R
 
 
R
 
R
 
Figure 6.1.2  all configurations of 2-by-2 chessboard
 
Your task is to write a program to calculate the number of configurations in n-by-n chessboard.

Input

The input is a sequence of positive integers each in a separate line. The integers are between 1 and 100, inclusive, indicating the size of the chessboard. The end of the input is indicated by a zero.

Output

The output should be composed of lines each corresponding to an input line except the last zero. An output line includes the number of configurations of the chessboard with the input size. No other characters should be inserted in the output.

Sample Input

2
0

Sample Output

3

Problem Source

系列热身赛5@2011年上半学期算法考试和4+2选拔赛

// Problem#: 2679
// Submission#: 3592109
// The source code is licensed under Creative Commons Attribution-NonCommercial-ShareAlike 3.0 Unported License
// URI: http://creativecommons.org/licenses/by-nc-sa/3.0/
// All Copyright reserved by Informatic Lab of Sun Yat-sen University
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

class BigInteger {

    static const int MAXN_LEN = 2000;

    int d[MAXN_LEN];

    int len;

public:

    BigInteger(int v = 0) {

        memset(d, 0, sizeof(d));

        len = 0;

        while (v > 0) {

            d[len++] = v % 10;

            v /= 10;

        }

        if (len == 0) len = 1;

    }

    BigInteger operator + (const BigInteger other) const {

        BigInteger ret;

        ret.len = max(len, other.len);

        for (int i = 0; i < ret.len; i++) ret.d[i] = d[i] + other.d[i];

        for (int i = 0; i < ret.len; i++) {

            if (ret.d[i] > 9) {

                ret.d[i] -= 10;

                ret.d[i + 1]++;

            }

        }

        if (ret.d[ret.len] > 0) ret.len++;

        return ret;

    }

    BigInteger operator * (const BigInteger other) const {

        BigInteger ret;

        ret.len = len + other.len - 1;

        for (int i = 0; i < len; i++)

            for (int j = 0; j < other.len; j++) ret.d[i + j] += d[i] * other.d[j];

        for (int i = 0; i < ret.len; i++)

            if (ret.d[i] > 9) {

                ret.d[i + 1] += ret.d[i] / 10;

                ret.d[i] %= 10;

            }

        if (ret.d[ret.len] > 0) ret.len++;

        while (ret.len > 1 && ret.d[ret.len - 1] == 0) ret.len--;

        return ret;

    }

    void print() {

        for (int i = len - 1; i >= 0; i--) printf("%d", d[i]);
        printf("\n");

    }

};

BigInteger ans[110], dp[110][110];
BigInteger sum;

int main() {
    int i, j;
    dp[1][0] = 1;
    ans[1] = 1;
    for (i = 2; i <= 100; i++) {
        sum = 0;
        for (j = 0; j < i; j++) {
            sum = sum + dp[i - 1][j];
            dp[i][j] = sum * (i - j);
            ans[i] = ans[i] + dp[i][j];
        }
    }
    int n;
    while (scanf("%d", &n) && n) ans[n].print();
    return 0;
}                                 


深度学习是机器学习的一个子领域,它基于人工神经网络的研究,特别是利用多层次的神经网络来进行学习和模式识别。深度学习模型能够学习数据的高层次特征,这些特征对于图像和语音识别、自然语言处理、医学图像分析等应用至关重要。以下是深度学习的一些关键概念和组成部分: 1. **神经网络(Neural Networks)**:深度学习的基础是人工神经网络,它是由多个层组成的网络结构,包括输入层、隐藏层和输出层。每个层由多个神经元组成,神经元之间通过权重连接。 2. **前馈神经网络(Feedforward Neural Networks)**:这是最常见的神经网络类型,信息从输入层流向隐藏层,最终到达输出层。 3. **卷积神经网络(Convolutional Neural Networks, CNNs)**:这种网络特别适合处理具有网格结构的数据,如图像。它们使用卷积层来提取图像的特征。 4. **循环神经网络(Recurrent Neural Networks, RNNs)**:这种网络能够处理序列数据,如时间序列或自然语言,因为它们具有记忆功能,能够捕捉数据中的时间依赖性。 5. **长短期记忆网络(Long Short-Term Memory, LSTM)**:LSTM 是一种特殊的 RNN,它能够学习长期依赖关系,非常适合复杂的序列预测任务。 6. **生成对抗网络(Generative Adversarial Networks, GANs)**:由两个网络组成,一个生成器和一个判别器,它们相互竞争,生成器生成数据,判别器评估数据的真实性。 7. **深度学习框架**:如 TensorFlow、Keras、PyTorch 等,这些框架提供了构建、训练和部署深度学习模型的工具和库。 8. **激活函数(Activation Functions)**:如 ReLU、Sigmoid、Tanh 等,它们在神经网络中用于添加非线性,使得网络能够学习复杂的函数。 9. **损失函数(Loss Functions)**:用于评估模型的预测与真实值之间的差异,常见的损失函数包括均方误差(MSE)、交叉熵(Cross-Entropy)等。 10. **优化算法(Optimization Algorithms)**:如梯度下降(Gradient Descent)、随机梯度下降(SGD)、Adam 等,用于更新网络权重,以最小化损失函数。 11. **正则化(Regularization)**:技术如 Dropout、L1/L2 正则化等,用于防止模型过拟合。 12. **迁移学习(Transfer Learning)**:利用在一个任务上训练好的模型来提高另一个相关任务的性能。 深度学习在许多领域都取得了显著的成就,但它也面临着一些挑战,如对大量数据的依赖、模型的解释性差、计算资源消耗大等。研究人员正在不断探索新的方法来解决这些问题。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值