Sicily 1717. Computer

1717. Computer

Constraints

Time Limit: 2 secs, Memory Limit: 32 MB

Description

We often hear that computer is a magic, a great invention, or even a marvel. But actually computer is just a tool people use everyday. It is a machine that can help people to process many jobs effectively. Moreover, without computer, you can not play ICPC. So, guys, let’s study some stuff about computer here.
One computer has one CPU (Central Processing Unit). CPU can be idle or processing one job at any time. Jobs come randomly and are stored in the memory until finished. CPU will process jobs according to some strategies. The processing job can be interrupted and saved back so that CPU can be available for other jobs. 
Each job has a release time and a processing time. Assume that we know the schedule of all jobs, please generate a program to minimize the sum of completion times of all jobs using a strategy which assigns and interrupts jobs properly.
For example, suppose there are two jobs to be completed. Job 1 is released at time 1 and needs 4 time units to process. Job 2’s release time and processing time is 3 and 1. Figures below show three solutions:


Figure 1 shows a solution with the total complete time 4 + 6 = 10, and the result of Figure 2 and 3 are both 5 + 6 = 11. In fact, Figure 1 shows the optimal solution 
Please note that all of the jobs will be released, interrupted and assigned in integer time unit.

Input

Input may consist of multiple test cases.
Every test case begins with a line that contains one integer n (1<= n <= 50000) denoting the number of jobs. Each of the following n lines contains 2 integers: ri and pi, (1 <= ri <= 10^9, 1 <= pi <= 10000) denoting the release time and processing time of job i.
Input is terminated by EOF.

Output

For every test case, print one line with an integer denoting the minimum sum of completion times.

Sample Input

2
1 4
3 1

Sample Output

10

// Problem#: 1717
// Submission#: 3585103
// The source code is licensed under Creative Commons Attribution-NonCommercial-ShareAlike 3.0 Unported License
// URI: http://creativecommons.org/licenses/by-nc-sa/3.0/
// All Copyright reserved by Informatic Lab of Sun Yat-sen University
#include <stdio.h>
#include <algorithm>
#include <queue>
#include <vector>
using namespace std;

int n;
struct node {
    int start, len;
};

node arr[50100];

bool cmp(const node & n1, const node & n2) {
    if (n1.start != n2.start) return n1.start < n2.start;
    return n1.len < n2.len;
}

void process() {
    int i;
    long long time, sum = 0;
    for (i = 0; i < n; i++) scanf("%d%d", &arr[i].start, &arr[i].len);
    sort(arr, arr + n, cmp);
    time = arr[0].start;
    
    priority_queue<int, vector<int>, greater<int> > q;
    q.push(arr[0].len);
    
    int index = 1;
    while (1) {
        while (!q.empty()) {
            i = q.top();
            q.pop();
            if (index >= n) {
                time += i;
                sum += time;
                continue;
            }
            if (time + i <= arr[index].start) {
                time += i;
                sum += time;
                continue;
            }
            i = i - (arr[index].start - time);
            q.push(i);
            i = index;
            time = arr[index].start;
            while (1) {
                if (arr[index].start != arr[i].start) break;
                q.push(arr[index].len);
                index++;
                if (index >= n) break;
            }
        }
        if (index < n) {
            time = arr[index].start;
            q.push(arr[index].len);
            index++;
        } else break;
    }
    printf("%lld\n", sum);
}

int main() {
    while (scanf("%d", &n) != EOF) process();
    return 0;
}                                 


内容概要:该题库专为研究生入学考试计算机组成原理科目设计,涵盖名校考研真题、经典教材课后习题、章节题库和模拟试题四大核心模块。名校考研真题精选多所知名高校的计算机组成原理科目及计算机联考真题,并提供详尽解析,帮助考生把握考研命题趋势与难度。经典教材课后习题包括白中英《计算机组成原理》(第5版)和唐朔飞《计算机组成原理》(第2版)的全部课后习题解答,这两部教材被众多名校列为考研指定参考书目。章节题库精选代表性考题,注重基础知识与重难点内容,帮助考生全面掌握考试大纲要求的知识点。模拟试题依据历年考研真题命题规律和热门考点,精心编制两套全真模拟试题,并附标准答案,帮助考生检验学习成果,评估应试能力。 适用人群:计划参加研究生入学考试并报考计算机组成原理科目的考生,尤其是需要系统复习和强化训练的学生。 使用场景及目标:①通过研读名校考研真题,考生可以准确把握考研命题趋势与难度,有效评估复习成效;②通过经典教材课后习题的练习,考生可以巩固基础知识,掌握解题技巧;③通过章节题库的系统练习,考生可以全面掌握考试大纲要求的各个知识点,为备考打下坚实基础;④通过模拟试题的测试,考生可以检验学习成果,评估应试能力,为正式考试做好充分准备。 其他说明:该题库不仅提供详细的题目解析,还涵盖了计算机组成原理的各个方面,包括计算机系统概述、数据表示与运算、存储器分层、指令系统、中央处理器、总线系统和输入输出系统等。考生在使用过程中应结合理论学习与实践操作,注重理解与应用,以提高应试能力和专业知识水平。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值