Sicily 1717. Computer

1717. Computer

Constraints

Time Limit: 2 secs, Memory Limit: 32 MB

Description

We often hear that computer is a magic, a great invention, or even a marvel. But actually computer is just a tool people use everyday. It is a machine that can help people to process many jobs effectively. Moreover, without computer, you can not play ICPC. So, guys, let’s study some stuff about computer here.
One computer has one CPU (Central Processing Unit). CPU can be idle or processing one job at any time. Jobs come randomly and are stored in the memory until finished. CPU will process jobs according to some strategies. The processing job can be interrupted and saved back so that CPU can be available for other jobs. 
Each job has a release time and a processing time. Assume that we know the schedule of all jobs, please generate a program to minimize the sum of completion times of all jobs using a strategy which assigns and interrupts jobs properly.
For example, suppose there are two jobs to be completed. Job 1 is released at time 1 and needs 4 time units to process. Job 2’s release time and processing time is 3 and 1. Figures below show three solutions:


Figure 1 shows a solution with the total complete time 4 + 6 = 10, and the result of Figure 2 and 3 are both 5 + 6 = 11. In fact, Figure 1 shows the optimal solution 
Please note that all of the jobs will be released, interrupted and assigned in integer time unit.

Input

Input may consist of multiple test cases.
Every test case begins with a line that contains one integer n (1<= n <= 50000) denoting the number of jobs. Each of the following n lines contains 2 integers: ri and pi, (1 <= ri <= 10^9, 1 <= pi <= 10000) denoting the release time and processing time of job i.
Input is terminated by EOF.

Output

For every test case, print one line with an integer denoting the minimum sum of completion times.

Sample Input

2
1 4
3 1

Sample Output

10

// Problem#: 1717
// Submission#: 3585103
// The source code is licensed under Creative Commons Attribution-NonCommercial-ShareAlike 3.0 Unported License
// URI: http://creativecommons.org/licenses/by-nc-sa/3.0/
// All Copyright reserved by Informatic Lab of Sun Yat-sen University
#include <stdio.h>
#include <algorithm>
#include <queue>
#include <vector>
using namespace std;

int n;
struct node {
    int start, len;
};

node arr[50100];

bool cmp(const node & n1, const node & n2) {
    if (n1.start != n2.start) return n1.start < n2.start;
    return n1.len < n2.len;
}

void process() {
    int i;
    long long time, sum = 0;
    for (i = 0; i < n; i++) scanf("%d%d", &arr[i].start, &arr[i].len);
    sort(arr, arr + n, cmp);
    time = arr[0].start;
    
    priority_queue<int, vector<int>, greater<int> > q;
    q.push(arr[0].len);
    
    int index = 1;
    while (1) {
        while (!q.empty()) {
            i = q.top();
            q.pop();
            if (index >= n) {
                time += i;
                sum += time;
                continue;
            }
            if (time + i <= arr[index].start) {
                time += i;
                sum += time;
                continue;
            }
            i = i - (arr[index].start - time);
            q.push(i);
            i = index;
            time = arr[index].start;
            while (1) {
                if (arr[index].start != arr[i].start) break;
                q.push(arr[index].len);
                index++;
                if (index >= n) break;
            }
        }
        if (index < n) {
            time = arr[index].start;
            q.push(arr[index].len);
            index++;
        } else break;
    }
    printf("%lld\n", sum);
}

int main() {
    while (scanf("%d", &n) != EOF) process();
    return 0;
}                                 


内容概要:本文档提供了三种神经网络控制器(NNPC、MRC和NARMA-L2)在机器人手臂模型上性能比较的MATLAB实现代码及详细解释。首先初始化工作空间并设定仿真参数,包括仿真时间和采样时间等。接着定义了机器人手臂的二阶动力学模型参数,并将其转换为离散时间系统。对于参考信号,可以选择方波或正弦波形式。然后分别实现了三种控制器的具体算法:MRC通过定义参考模型参数并训练神经网络来实现控制;NNPC利用预测模型神经网络并结合优化算法求解控制序列;NARMA-L2则通过两个神经网络分别建模f和g函数,进而实现控制律。最后,对三种控制器进行了性能比较,包括计算均方根误差、最大误差、调节时间等指标,并绘制了响应曲线和跟踪误差曲线。此外,还强调了机器人手臂模型参数的一致性和参考信号设置的规范性,提出了常见问题的解决方案以及性能比较的标准化方法。 适合人群:具备一定编程基础,特别是熟悉MATLAB编程语言的研究人员或工程师,以及对神经网络控制理论有一定了解的技术人员。 使用场景及目标:①理解不同类型的神经网络控制器的工作原理;②掌握在MATLAB中实现这些控制器的方法;③学会如何设置合理的参考信号并保证模型参数的一致性;④能够根据具体的性能指标对比不同控制器的效果,从而选择最适合应用场景的控制器。 其他说明:本文档不仅提供了完整的实验代码,还对每个步骤进行了详细的注释,有助于读者更好地理解每段代码的功能。同时,针对可能出现的问题给出了相应的解决办法,确保实验结果的有效性和可靠性。为了使性能比较更加公平合理,文档还介绍了标准化的测试流程和评估标准,这对于进一步研究和应用具有重要的指导意义。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值