Sicily 1527. Tiling a Grid With Dominoes

1527. Tiling a Grid With Dominoes

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

We wish to tile a grid 4 units high and N units long with rectangles (dominoes) 2 units by one unit (in either orientation). For example, the figure shows the five different ways that a grid 4 units high and 2 units wide may be tiled.

 

\epsfbox{p3917.eps}

Write a program that takes as input the width, W , of the grid and outputs the number of different ways to tile a 4-by-W grid.

Input

The first line of input contains a single integer N , (1<=N<=1000) which is the number of datasets that follow.

Each dataset contains a single decimal integer, the width, W , of the grid for this problem instance.

Output

For each problem instance, there is one line of output: The problem instance number as a decimal integer (start counting at one), a single space and the number of tilings of a 4-by-W grid. The values of W will be chosen so the count will fit in a 32-bit integer.

Sample Input

3 
2 
3 
7

Sample Output

1 5 
2 11 
3 781

Problem Source

Greater New York 2007

// Problem#: 1527
// Submission#: 3318407
// The source code is licensed under Creative Commons Attribution-NonCommercial-ShareAlike 3.0 Unported License
// URI: http://creativecommons.org/licenses/by-nc-sa/3.0/
// All Copyright reserved by Informatic Lab of Sun Yat-sen University
#include <algorithm>
#include <iostream>
#include <string>
#include <stdio.h>
#include <queue>
#include <string.h>
#include <vector>
#include <iomanip>
#include <map>
#include <stack>
#include <functional>
#include <list>
#include <cmath>
using namespace std;

const int MAX_N = 1005;

int dp[MAX_N][16];

int main() {

    std::ios::sync_with_stdio(false);

    dp[1][0] = dp[1][3] = dp[1][6] = dp[1][12] = dp[1][15] = 1;

    for (int i = 2; i < MAX_N; i++) {

        for (int j = 0; j <= 15; j++) dp[i][j] += dp[i - 1][15 - j];

        //竖放0个
        //dp[i][0] += dp[i - 1][15];

        //竖放1个
        dp[i][3] += dp[i - 1][15];
        dp[i][6] += dp[i - 1][15];
        dp[i][12] += dp[i - 1][15];

        dp[i][7] += dp[i][1];
        dp[i][13] += dp[i][1];  // ?
        dp[i][14] += dp[i][2];
        dp[i][7] += dp[i][4];
        dp[i][14] += dp[i][8];
        dp[i][11] += dp[i][8];  // ?

        //竖放两个
        dp[i][15] += dp[i - 1][15];

        //混合2横一竖
        dp[i][15] += dp[i - 1][3];
        dp[i][15] += dp[i - 1][6];
        dp[i][15] += dp[i - 1][12];

    }

    int n;
    cin >> n;
    for (int i = 1; i <= n; i++) {
        int pos;
        cin >> pos;
        cout << i << " " << dp[pos][15] << endl;
    }


    //getchar();
    //getchar();
    
    return 0;
}                                 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值