Sicily 1085. Longge's problem

1085. Longge's problem

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

Longge is good at mathematics and he likes to think about hard mathematical problems which will be solved by some graceful algorithms. Now a problem comes: Given an integer N(1<N<2^31),you are to calculate   gcd(i, N) 1<=i <=N.

“Oh, I know, I know!” Longge shouts! But do you know? Please solve it.

Input

A number N per line.

Output

For each N, output ,∑gcd(i, N) 1<=i <=N, a line .

Sample Input

2
6

Sample Output

3

15

// Problem#: 1085
// Submission#: 3257689
// The source code is licensed under Creative Commons Attribution-NonCommercial-ShareAlike 3.0 Unported License
// URI: http://creativecommons.org/licenses/by-nc-sa/3.0/
// All Copyright reserved by Informatic Lab of Sun Yat-sen University
#include <stdio.h>

int main() {

    //std::ios::sync_with_stdio(false);
    long long N, ans, kn, pnkn;
    while (scanf("%lld", &N) != EOF) {
        ans = 1;
        for (long long int i = 2; i * i <= N; i++) {
            if (N % i == 0) {
                kn = 0, pnkn = 1;
                while (N % i == 0) {
                    pnkn *= i;
                    kn++;
                    N /= i;
                }
                ans *= kn * (pnkn - pnkn / i) + pnkn;
            }
        }
        printf("%lld\n", ans * (2 * N - 1));
    }

    //getchar();
    //getchar();
    
    return 0;
}                                 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值