Sicily T-primes

Description

We know that prime numbers are positive integers that have exactly two distinct positive divisors. 

Similarly, we'll call a positive integer t Т-prime, if t has exactly three distinct positive divisors。

You are given an array of n positive integers. For each of them determine whether it is Т-prime or not.

Input

The first line contains a single positive integer, n (1?≤?n?≤?10000),showing how many numbers are in the array. 

The next line contains n space-separated integers xi (1?≤?xi?≤?10^12).

Output

Print one line: The number of T-primes number

Sample Input
 Copy sample input to clipboard
3
4 5 6
Sample Output
1
Hint

Please use long long instead of int for any Xi.

The given test has three numbers. 

The first number 4 has exactly three divisors — 1, 2 and 4. 

The second number 5 has two divisors (1 and 5), 

The third number 6 has four divisors (1, 2, 3, 6),

hence the answer for them is 1 (only the number 4 is T-primes number).

师弟问到的题目,注意到数据很大。
如果一个数是素数的平方,那么这个数有且仅有三个因子。
#include<iostream>
#include<math.h>
using namespace std;

bool prime[1000001];

void make_prime() {
    for (int i = 0; i < 1000001; i++) prime[i] = true;
    for (int i = 2; i < 1000001; i++) {
        if (prime[i]) {
            for (int j = 2; j * i < 1000001; j++) {
                prime[i * j] = false;
            }
        }
    }
}

int main()
{
    std::cout.sync_with_stdio(false);
    make_prime();

    int n, ans = 0;
    cin>>n;
    while(n--)
    {
        long long temp;
        cin >> temp;
        double truepos = sqrt(temp);
        long long pos = (int)sqrt(temp);
        if (temp >= 4 && truepos - pos == 0 && prime[pos]) ans++;

    }
    cout<<ans<< endl;

    //getchar();

    return 0;
}                                 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值