Sicily 1504. Slim Span

1504. Slim Span

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

Given an undirected weighted graph G, you should find one of spanning trees specified as follows.

The graph G is an ordered pair (VE), where V is a set of vertices {v1,v2, , vn} and E is a set of undirected edges {e1e2, , em}. Each edgee ? E has its weight w(e).

A spanning tree T is a tree (a connected subgraph without cycles) which connects all the n vertices with n ? 1 edges. The slimness of a spanning tree T is defined as the difference between the largest weight and the smallest weight among the n ? 1 edges of T.


Figure 5: A graph  G and the weights of the edges

For example, a graph G in Figure 5(a) has four vertices {v1v2v3v4} and five undirected edges {e1e2e3e4e5}. The weights of the edges are w(e1) = 3, w(e2) = 5, w(e3) = 6, w(e4) = 6, w(e5) = 7 as shown in Figure 5(b).

Sicily 1504. Slim Span - Night -  
Figure 6: Examples of the spanning trees of  G

There are several spanning trees for G. Four of them are depicted in Figure 6(a)~(d). The spanning tree Ta in Figure 6(a) has three edges whose weights are 3, 6 and 7. The largest weight is 7 and the smallest weight is 3 so that the slimness of the tree Ta is 4. The slimnesses of spanning trees TbTc and Td shown in Figure 6(b), (c) and (d) are 3, 2 and 1, respectively. You can easily see the slimness of any other spanning tree is greater than or equal to 1, thus the spanning tree Td in Figure 6(d) is one of the slimmest spanning trees whose slimness is 1.

Your job is to write a program that computes the smallest slimness.

Input

The input consists of multiple datasets, followed by a line containing two zeros separated by a space. Each dataset has the following format.

nm 
a1b1w1
 ? 
ambmwm

Every input item in a dataset is a non-negative integer. Items in a line are separated by a space. n is the number of the vertices and m the number of the edges. You can assume 2 ? n ? 100 and 0 ? m ? n(n ? 1)/2. ak and bk (k = 1, , m) are positive integers less than or equal ton, which represent the two vertices vak and vbk connected by the kth edge ekwk is a positive integer less than or equal to 10000, which indicates the weight of ek. You can assume that the graph G = (VE) is simple, that is, there are no self-loops (that connect the same vertex) nor parallel edges (that are two or more edges whose both ends are the same two vertices).

Output

For each dataset, if the graph has spanning trees, the smallest slimness among them should be printed. Otherwise, ?1 should be printed. An output should not contain extra characters.

Sample Input

de style="color: rgb(51, 51, 51); font-size: 18.01801872253418px; line-height: 27.027027130126953px;" >
4 5
1 2 3
1 3 5
1 4 6
2 4 6
3 4 7
4 6
1 2 10
1 3 100
1 4 90
2 3 20
2 4 80
3 4 40
2 1
1 2 1
3 0
3 1
1 2 1
3 3
1 2 2
2 3 5
1 3 6
5 10
1 2 110
1 3 120
1 4 130
1 5 120
2 3 110
2 4 120
2 5 130
3 4 120
3 5 110
4 5 120
5 10
1 2 9384
1 3 887
1 4 2778
1 5 6916
2 3 7794
2 4 8336
2 5 5387
3 4 493
3 5 6650
4 5 1422
5 8
1 2 1
2 3 100
3 4 100
4 5 100
1 5 50
2 5 50
3 5 50
4 1 150
0 0
de>

Sample Output

de style="color: rgb(51, 51, 51); font-size: 18.01801872253418px; line-height: 27.027027130126953px;" >
1
20
0
-1
-1
1
0
1686
50
de>

Problem Source

Tokyo 2007

求最大边和最小边之差最小的生成树,答案输出最小差。

取定某一条边,以此边开始用kruskal方法做最小生成树,那么得到的最大边是尽量小的最大边。

于是,将所有的边从小到大排序,并遍历各边,以各边开始(此时最小边已经确定)做最小生成树,得到对应的尽量小的最大边,计算差值,更新答案。

#include <algorithm>
#include <iostream>
#include <string>
#include <stdio.h>
#include <queue>
#include <string.h>
#include <vector>
#include <iomanip>
#include <map>
#include <stack>
#include <functional>
#include <list>
#include <math.h>
using namespace std;

#define MAX_N 105
#define INF 2000000000

struct edge{
    int u;
    int v;
    int cost;
};

vector<edge> G;
double x;
int n;
int m;

int par[MAX_N];

void init(int n) {
    for (int i = 1; i <= n; i++) {
        par[i] = i;
    }
}

int find(int x) {
    if (par[x] == x) return x;
    par[x] = find(par[x]);
    return par[x];
}

void unite(int x, int y) {
    x = find(x);
    y = find(y);
    
    if (x == y) return;

    par[x] = y;
}

bool same(int x, int y) {
    return find(x) == find(y);
}

bool cmp(edge e1, edge e2) {
    return e1.cost < e2.cost;
}

int kruskal(int st) {

    init(n);
    
    edge lastEdge;

    int eNum = 0;

    for (int i = st; i < m; i++) {
        edge e = G[i];
        if (!same(e.u, e.v)) {
            unite(e.u, e.v);
            eNum++;
            if (eNum == n - 1) {
                return G[i].cost - G[st].cost;
                break;
            }
        }
    }

    return INF;

}

int main() {

    std::ios::sync_with_stdio(false);

    while (1) {

        cin >> n >> m;

        if (n == 0 && m == 0) break;

        G.clear();
        G.resize(m);

        for (int i = 0; i < m; i++)  cin >> G[i].u >> G[i].v >> G[i].cost;


        int ans = INF;

        sort(G.begin(), G.end(), cmp);

        for (int i = 0; i <= m - (n - 1); i++) {

            int newAns = kruskal(i);

            if (newAns < ans) ans = newAns;

        }

        cout << ans << endl;

    }

    //getchar();
    //getchar();
    
    return 0;
}            

此处贴上自己写的错误代码:

int kruskal(int st) {

    init(n);
    
    edge lastEdge;

    int eNum = 0;

    for (int i = st; i < m; i++) {
        edge e = G[i];
        if (!same(e.u, e.v)) {
            unite(e.u, e.v);
            eNum++;
            lastEdge = e;
            if (eNum == n - 1) break;
        }
    }

    return lastEdge.cost - G[st].cost;

}
不同之处就在于上面的函数,注意到在错误代码中,如果st达到了一定大的值,以st到m-1这些边有可能是不能生成最小生成树的(边会越来越少),但错误代码中在这种情况下依然会返回差值,这就是错误原因。





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值