Sicily 13915. Sequence

13915. Sequence

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

 

Input

 

Output

 

Sample Input

样例一:
1
2
样例二:
4
3 2 3 5
样例三:
5
1 2 2 3 4

Sample Output

样例一:
2
样例二:
3 1 5 11
样例三:
1 3 2 6 8

Hint

 

Problem Source

2015年每周一赛第三场

注意数值范围即可。

// Problem#: 13915
// Submission#: 3638790
// The source code is licensed under Creative Commons Attribution-NonCommercial-ShareAlike 3.0 Unported License
// URI: http://creativecommons.org/licenses/by-nc-sa/3.0/
// All Copyright reserved by Informatic Lab of Sun Yat-sen University
#include <iostream>
using namespace std;

int main() {
    int n, k = 2;
    long long int sum = 0, temp;
    cin >> n >> sum;
    cout << sum;
    while (--n) {
        cin >> temp;
        cout << " " << temp * k - sum;
        sum = temp * (k++);
    }
    cout << endl;
    return 0;
}                                 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值