Sicily 1118. War on Weather

1118. War on Weather

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

After an unprovoked hurricane attack on the south shore, Glorious Warrior has declared war on weather. The first salvo in this campaign will be a coordinated pre-emptive attack on as many tropical depressions as possible. GW reckons that the attack will neutralize the tropical depressions before they become storms, and dissuade others from forming.

GW has at his disposal k space-to-earth killer satellites at various locations in space. m tropical depressions are known to exist at various locations on the earth's surface. Each satellite can attack any number of targets on the earth provided there is line of sight between the satellite and each target. How many different targets can be hit?

Input

The input consists of several test cases. Each case begins with a line containing integers 0 < k, m &le 100 as defined above. k lines follow, each giving x,y,z - the location in space of a satellite at the scheduled time of attack. m lines then follow, each giving x,y,z - the location of a target tropical depression. Assume the earth is a sphere centred at (0,0,0) with circumference 40,000 km. All targets will be on the surface of the earth (within 10-9 km) and all satellites will be at least 50 km above the surface. A line containing 0 0 follows the last test case.

Output

For each test case, output a line giving the total number of targets that can be hit. If a particular target falls within 10-8 km of the boundary between being within line-of-sight and not, it may be counted either way. (That is, you need not consider rounding error so long as it does not exceed 10-8 km.)

Sample Input

3 2
-10.82404031 -1594.10929753 -6239.77925152
692.58497298 -5291.64700245 4116.92402298
3006.49210582 2844.61925179 5274.03201053
2151.03635167 2255.29684503 5551.13972186
-1000.08700886 -4770.25497971 4095.48127333
3 4
0 0 6466.197723676
0 6466.197723676 0
6466.197723676 0 0
6366.197723676 0 0
6365.197723676 112.833485488 0
0 0 6366.197723676
0 -6366.197723676 0
0 0

Sample Output

2
3

其实就是问你在一个球上的点能否被另一个点射到。。用法向量吧,题目中有提到误差的处理,看到误差那么小果断不处理了,结果过了- -


如上图,cosATC >= 0 , cosBTC < 0所以点A可以射到target,B不行;
#include <stdio.h>
#include <math.h>

int main() {
    int k, m;
    double killer[101][3];
    while (scanf("%d%d", &k, &m) && k && m) {
        for (int i = 0; i < k; i++) {
            scanf("%lf%lf%lf", &killer[i][0], &killer[i][1], &killer[i][2]);
        }
        int counter = 0;
        while (m--) {
            double x, y, z;
            scanf("%lf%lf%lf", &x, &y, &z);
            for (int i = 0; i < k; i++) {
                double x1 = killer[i][0] - x;
                double y1 = killer[i][1] - y;
                double z1 = killer[i][2] - z;
                double coss = (x1 * x + y1 * y + z1 * z) / (sqrt(x * x + y * y + z * z) * sqrt(x1 * x1 + y1 * y1 + z1 * z1));
                if (coss >= 0) {
                    counter++;
                    break;
                }
            }
        }
        printf("%d\n", counter);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值