Sicily 9562. SUME

9562. SUME

Constraints

Time Limit: 1 secs, Memory Limit: 256 MB

Description

Once upon a time, there existed a sequence A consisting of N positive integers. You don't know the sequence itself, but you do know the sum of every two elements of the sequence. Find the sequence A!

Input

The first line of input contains the positive integer N (2 ≤ N ≤ 1000).
Each of the following N lines contains N positive integers smaller than or equal to 100 000, forming the table S. The following relations hold: S(i, j) = A[i] + A[j] for i ≠ j, and S(i, j) = 0 for i = j. Here S(i, j) denotes the number in the ith row and jth column of the table, and A[i] denotes the ith element of the sequence A.
It is guaranteed that for any input data set there exists a unique sequence of positive integers A with the given properties.

Output

The first and only line of output must contain the required sequence A (in the form of N space-separated positive integers).

Sample Input

2 
0 2 
2 0

Sample Output

1 1

Problem Source

2013年每周一赛第十四场

这道题还是蛮好玩的,构造方程,求解,注意这里要构造三个方程,

a[i] + a[j] = s[i][j];
a[j] + a[k] = s[j][k];
a[k] + a[i] = s[k][i];
这样才能求出来,然后发现,其实不用读完全部的数字都可以求解了,于是。。。

第一遍,0.49s:
#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <string.h>
#include <string>
using namespace std;

int s[1005][1005];

int main() {
    int i, j, k, a[1005], n;
    
    scanf("%d", &n);
    for (i = 0; i < n; i++) {
        for (j = 0; j < n; j++) {
            scanf("%d", &s[i][j]);
        }
    }
    
    memset(a, 0, sizeof(a));
    /*for (i = 0; i < n && n >= 3; i++) {
        for (j = i + 1; j < n; j++) {
            for (k = j + 1; k < n; k++) {
                a[i] = (s[i][j] - s[j][k] + s[k][i]) / 2;
                a[j] = s[i][j] - a[i];
                a[k] = s[i][k] - a[i];
            }
        }
    }*/
    
    if (n >= 3) {
        a[0] = (s[0][1] - s[1][2] + s[2][0]) / 2;
        a[1] = s[0][1] - a[0];
        for (k = 2; k < n; k++) {
            a[k] = s[0][k] - a[0];
        }
    }
    
    if (n == 2) {
        printf("1 1\n");
    } else {
        printf("%d", a[0]);
        for (i = 1; i < n; i++) {
            printf(" %d", a[i]);
        }
        printf("\n");
    }
    
    return 0;
}                                 
第二遍,读入2n + 1个数就可以求解,程序还没输入完成我就输出,能不快吗?也就是第一行第二个数,第二行第三个数,第三行第一个数(0s):

#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <string.h>
#include <string>
using namespace std;

int main() {
    int i, k, a[2], n, temp, s[1005], s12, s20;
    
    scanf("%d", &n);
    /*for (i = 0; i < n; i++) {
        for (j = 0; j < n; j++) {
            scanf("%d", &s[i][j]);
        }
    }*/
    
    memset(a, 0, sizeof(a));
    /*for (i = 0; i < n && n >= 3; i++) {
        for (j = i + 1; j < n; j++) {
            for (k = j + 1; k < n; k++) {
                a[i] = (s[i][j] - s[j][k] + s[k][i]) / 2;
                a[j] = s[i][j] - a[i];
                a[k] = s[i][k] - a[i];
            }
        }
    }*/
    
    if (n >= 3) {
        for (i = 0; i < n; i++) {
            scanf("%d", &s[i]);
        }
        for (i = 0; i < n + 1; i++) {
            scanf("%d", &temp);
            if (i == 2)
                s12 = temp;
            if (i == n)
                s20 = temp;
        }
        a[0] = (s[1] - s12 + s20) / 2;
        a[1] = s[1] - a[0];
        printf("%d %d", a[0], a[1]);
        for (k = 2; k < n; k++) {
            printf(" %d", s[k] - a[0]);
        }
        printf("\n");
    }
    
    if (n == 2) {
        printf("1 1\n");
    }
    return 0;
}          



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
在信号处理领域,DOA(Direction of Arrival)估计是一项关键技术,主要用于确定多个信号源到达接收阵列的方向。本文将详细探讨三种ESPRIT(Estimation of Signal Parameters via Rotational Invariance Techniques)算法在DOA估计中的实现,以及它们在MATLAB环境中的具体应用。 ESPRIT算法是由Paul Kailath等人于1986年提出的,其核心思想是利用阵列数据的旋转不变性来估计信号源的角度。这种算法相比传统的 MUSIC(Multiple Signal Classification)算法具有较低的计算复杂度,且无需进行特征值分解,因此在实际应用中颇具优势。 1. 普通ESPRIT算法 普通ESPRIT算法分为两个主要步骤:构造等效旋转不变系统和估计角度。通过空间平移(如延时)构建两个子阵列,使得它们之间的关系具有旋转不变性。然后,通过对子阵列数据进行最小二乘拟合,可以得到信号源的角频率估计,进一步转换为DOA估计。 2. 常规ESPRIT算法实现 在描述中提到的`common_esprit_method1.m`和`common_esprit_method2.m`是两种不同的普通ESPRIT算法实现。它们可能在实现细节上略有差异,比如选择子阵列的方式、参数估计的策略等。MATLAB代码通常会包含预处理步骤(如数据归一化)、子阵列构造、旋转不变性矩阵的建立、最小二乘估计等部分。通过运行这两个文件,可以比较它们在估计精度和计算效率上的异同。 3. TLS_ESPRIT算法 TLS(Total Least Squares)ESPRIT是对普通ESPRIT的优化,它考虑了数据噪声的影响,提高了估计的稳健性。在TLS_ESPRIT算法中,不假设数据噪声是高斯白噪声,而是采用总最小二乘准则来拟合数据。这使得算法在噪声环境下表现更优。`TLS_esprit.m`文件应该包含了TLS_ESPRIT算法的完整实现,包括TLS估计的步骤和旋转不变性矩阵的改进处理。 在实际应用中,选择合适的ESPRIT变体取决于系统条件,例如噪声水平、信号质量以及计算资源。通过MATLAB实现,研究者和工程师可以方便地比较不同算法的效果,并根据需要进行调整和优化。同时,这些代码也为教学和学习DOA估计提供了一个直观的平台,有助于深入理解ESPRIT算法的工作原理。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值