华为模拟器ensp AC+AP AP 在ac中的漫游

1.新MAC 移动设备在AC注册后,其中的会保存在注册的AC中,包括VLAN ,分配IP信息,

2.在移动到AC互联的网络中,其中的移动设备IP 是不变化的,和当前的VLAN无关,只和移动设备注册时候的vlan有联系

3.漫游要到每个AC都需要设置。

mobility-group name manyou
  member ip-address 10.0.10.10
  member ip-address 10.0.20.10

4.

[AC2]disp mobility-group name manyou
--------------------------------------------------------------------------------
State        IP address                       Description                       
--------------------------------------------------------------------------------

normal       10.0.10.10                       -                               
normal       10.0.20.10                       -                               
--------------------------------------------------------------------------------
Total: 2

拓扑图片如下

核心交换机代码

#
sysname sw1
#
undo info-center enable
#
vlan batch 10 20 100 to 101 200
#
cluster enable
ntdp enable
ndp enable
#
drop illegal-mac alarm
#
dhcp enable
#
diffserv domain default
#
drop-profile default
#
aaa
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default
 domain default_admin
 local-user admin password simple admin
 local-user admin service-type http
#
interface Vlanif1
#
interface Vlanif10
 ip address 10.0.10.1 255.255.255.0
 dhcp select interface
 dhcp server excluded-ip-address 10.0.10.10
 dhcp server option 43 sub-option 3 ascii 10.0.10.10
#
interface Vlanif20
 ip address 10.0.20.1 255.255.255.0
 dhcp select interface
 dhcp server excluded-ip-address 10.0.20.10
 dhcp server option 43 sub-option 3 ascii 10.0.20.10
#
interface Vlanif100
 ip address 192.168.100.1 255.255.255.0
 dhcp select interface
#
interface Vlanif101
 ip address 192.168.101.1 255.255.255.0
 dhcp select interface
#
interface Vlanif200
 ip address 192.168.200.1 255.255.255.0
 dhcp select interface
#
interface MEth0/0/1
#
interface GigabitEthernet0/0/1
 port link-type trunk
 port trunk allow-pass vlan 10 100 to 101
#
interface GigabitEthernet0/0/2
 port link-type trunk
 port trunk allow-pass vlan 20 200
#
interface GigabitEthernet0/0/3
 port link-type trunk
 port trunk pvid vlan 10
 port trunk allow-pass vlan 10 100
#
interface GigabitEthernet0/0/4
 port link-type trunk
 port trunk pvid vlan 10
 port trunk allow-pass vlan 10 101
#
interface GigabitEthernet0/0/5
 port link-type trunk
 port trunk pvid vlan 20
 port trunk allow-pass vlan 20 200
#
interface GigabitEthernet0/0/6
#
interface GigabitEthernet0/0/7
#
interface GigabitEthernet0/0/8
#
interface GigabitEthernet0/0/9
#
interface GigabitEthernet0/0/10
 port link-type access
 port default vlan 100
#
interface GigabitEthernet0/0/11
#
interface GigabitEthernet0/0/12
#
interface GigabitEthernet0/0/13
#
interface GigabitEthernet0/0/14
#
interface GigabitEthernet0/0/15
#
interface GigabitEthernet0/0/16
#
interface GigabitEthernet0/0/17
#
interface GigabitEthernet0/0/18
#
interface GigabitEthernet0/0/19
#
interface GigabitEthernet0/0/20
#
interface GigabitEthernet0/0/21
#
interface GigabitEthernet0/0/22
#
interface GigabitEthernet0/0/23
#
interface GigabitEthernet0/0/24
 port link-type access
 port default vlan 100
#
interface NULL0
#
user-interface con 0
user-interface vty 0 4
#
return

AC1 无线控制器代码

#
 set memory-usage threshold 0
#
ssl renegotiation-rate 1 
#
vlan batch 10 100 to 101 200
#
authentication-profile name default_authen_profile
authentication-profile name dot1x_authen_profile
authentication-profile name mac_authen_profile
authentication-profile name portal_authen_profile
authentication-profile name macportal_authen_profile
#
diffserv domain default
#
radius-server template default
#
pki realm default
 rsa local-key-pair default
 enrollment self-signed
#
ike proposal default
 encryption-algorithm aes-256 
 dh group14 
 authentication-algorithm sha2-256 
 authentication-method pre-share
 integrity-algorithm hmac-sha2-256 
 prf hmac-sha2-256 
#
free-rule-template name default_free_rule
#
portal-access-profile name portal_access_profile
#
aaa
 authentication-scheme default
 authentication-scheme radius
  authentication-mode radius
 authorization-scheme default
 accounting-scheme default
 domain default
  authentication-scheme radius
  radius-server default
 domain default_admin
  authentication-scheme default
 local-user admin password a12345678 aes
 local-user admin privilege level 15
 local-user admin service-type http
#
interface Vlanif10
 ip address 10.0.10.10 255.255.255.0
#
interface GigabitEthernet0/0/1
#
interface GigabitEthernet0/0/2
#
interface GigabitEthernet0/0/3
#
interface GigabitEthernet0/0/4
#
interface GigabitEthernet0/0/5
#
interface GigabitEthernet0/0/6
#
interface GigabitEthernet0/0/7
 undo negotiation auto
 duplex half
#
interface GigabitEthernet0/0/8
 port link-type trunk
 port trunk allow-pass vlan 10 100 to 101
 undo negotiation auto
 duplex half
#
interface NULL0
#
 snmp-agent local-engineid 800007DB03000000000000
 snmp-agent 
#
ssh server secure-algorithms cipher aes256_ctr aes128_ctr
ssh server key-exchange dh_group14_sha1
ssh client secure-algorithms cipher aes256_ctr aes128_ctr
ssh client secure-algorithms hmac sha2_256
ssh client key-exchange dh_group14_sha1
#
ip route-static 0.0.0.0 0.0.0.0 10.0.10.1
#
capwap source ip-address 10.0.10.10
#
user-interface con 0
 authentication-mode password
user-interface vty 0 4
 protocol inbound all
user-interface vty 16 20
 protocol inbound all
#
wlan
 traffic-profile name default
 security-profile name test
  security wpa2 psk pass-phrase a12345678 aes
 security-profile name default
 security-profile name test100
 security-profile name default-wds
 security-profile name default-mesh
 ssid-profile name test
  ssid test
 ssid-profile name default
 vap-profile name test1
 vap-profile name default
 vap-profile name test100
  service-vlan vlan-id 100
  ssid-profile test
  security-profile test
  home-agent ac
 vap-profile name test101
  service-vlan vlan-id 101
  ssid-profile test
  security-profile test
  home-agent ac
 wds-profile name default
 mesh-handover-profile name default
 mesh-profile name default
 regulatory-domain-profile name default
 air-scan-profile name default
 rrm-profile name default
 radio-2g-profile name default
 radio-5g-profile name default
 wids-spoof-profile name default
 wids-profile name default
 wireless-access-specification
 ap-system-profile name default
 port-link-profile name default
 wired-port-profile name default
 serial-profile name preset-enjoyor-toeap 
 mobility-group name manyou
  member ip-address 10.0.10.10
  member ip-address 10.0.20.10
 ap-group name default
 ap-group name test100
  radio 0
   vap-profile test100 wlan 1
  radio 1
   vap-profile test100 wlan 1
  radio 2
   vap-profile test100 wlan 1
 ap-group name test101
  radio 0
   vap-profile test101 wlan 1
  radio 1
   vap-profile test101 wlan 1
  radio 2
   vap-profile test101 wlan 1
 ap-id 0 type-id 45 ap-mac 00e0-fcab-2db0 ap-sn 210235448310D00BC763
  ap-name test
  ap-group test100
 ap-id 1 type-id 45 ap-mac 00e0-fcd3-7ae0 ap-sn 21023544831042776561
  ap-name test1
  ap-group test101
 ap-id 2 ap-mac 00e0-fcfc-06c0
  ap-name test3
 provision-ap
#
dot1x-access-profile name dot1x_access_profile
#
mac-access-profile name mac_access_profile
#
return

AC2无线控制器代码

#
 sysname AC2
#
 set memory-usage threshold 0
#
ssl renegotiation-rate 1 
#
vlan batch 20 100 to 101 200
#
authentication-profile name default_authen_profile
authentication-profile name dot1x_authen_profile
authentication-profile name mac_authen_profile
authentication-profile name portal_authen_profile
authentication-profile name macportal_authen_profile
#
diffserv domain default
#
radius-server template default
#
pki realm default
 rsa local-key-pair default
 enrollment self-signed
#
ike proposal default
 encryption-algorithm aes-256 
 dh group14 
 authentication-algorithm sha2-256 
 authentication-method pre-share
 integrity-algorithm hmac-sha2-256 
 prf hmac-sha2-256 
#
free-rule-template name default_free_rule
#
portal-access-profile name portal_access_profile
#
aaa
 authentication-scheme default
 authentication-scheme radius
  authentication-mode radius
 authorization-scheme default
 accounting-scheme default
 domain default
  authentication-scheme radius
  radius-server default
 domain default_admin
  authentication-scheme default
 local-user admin password a12345678 aes
 local-user admin privilege level 15
 local-user admin service-type http
#
interface Vlanif20
 ip address 10.0.20.10 255.255.255.0
#
interface GigabitEthernet0/0/1
#
interface GigabitEthernet0/0/2
#
interface GigabitEthernet0/0/3
#
interface GigabitEthernet0/0/4
#
interface GigabitEthernet0/0/5
#
interface GigabitEthernet0/0/6
#
interface GigabitEthernet0/0/7
 undo negotiation auto
 duplex half
#
interface GigabitEthernet0/0/8
 port link-type trunk
 port trunk allow-pass vlan 20 200
 undo negotiation auto
 duplex half
#
interface NULL0
#
 snmp-agent local-engineid 800007DB03000000000000
 snmp-agent 
#
ssh server secure-algorithms cipher aes256_ctr aes128_ctr
ssh server key-exchange dh_group14_sha1
ssh client secure-algorithms cipher aes256_ctr aes128_ctr
ssh client secure-algorithms hmac sha2_256
ssh client key-exchange dh_group14_sha1
#
ip route-static 0.0.0.0 0.0.0.0 10.0.20.1
#
capwap source ip-address 10.0.20.10
#
user-interface con 0
 authentication-mode password
user-interface vty 0 4
 protocol inbound all
user-interface vty 16 20
 protocol inbound all
#
wlan
 traffic-profile name default
 security-profile name test
  security wpa2 psk pass-phrase a12345678 aes
 security-profile name default
 security-profile name default-wds
 security-profile name default-mesh
 ssid-profile name test
  ssid test
 ssid-profile name default
 vap-profile name test
  forward-mode tunnel
  service-vlan vlan-id 200
  ssid-profile test
  security-profile test
 vap-profile name default
 vap-profile name test200
 wds-profile name default
 mesh-handover-profile name default
 mesh-profile name default
 regulatory-domain-profile name default
 air-scan-profile name default
 rrm-profile name default
 radio-2g-profile name default
 radio-5g-profile name default
 wids-spoof-profile name default
 wids-profile name default
 wireless-access-specification
 ap-system-profile name default
 port-link-profile name default
 wired-port-profile name default
 serial-profile name preset-enjoyor-toeap 
 mobility-group name manyou
  member ip-address 10.0.10.10
  member ip-address 10.0.20.10
 ap-group name test
  radio 0
   vap-profile test wlan 1
  radio 1
   vap-profile test wlan 1
  radio 2
   vap-profile test wlan 1
 ap-group name default
 ap-id 0 type-id 45 ap-mac 00e0-fcfc-06c0 ap-sn 2102354483104808BE14
  ap-name ap03
  ap-group test
 provision-ap
#
dot1x-access-profile name dot1x_access_profile
#
mac-access-profile name mac_access_profile
#
return

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
ENSP AC/AP漫游是指在ENSP网络仿真平台,通过设置ACAccess Controller)和APAccess Point)之间的漫游功能,实现在不同的AP之间无缝切换而不会断开连接。在漫游过程,用户设备可以在不同的AP之间进行自动切换,以获取更好的网络信号和服务质量。 具体操作步骤如下: 1. 首先,确保AC启动比较慢,等待1分钟后启动。可以通过命令行输入密码12345678来登录AC。 2. 接下来,使用命令ping 10.23.100.1 -t来测试漫游效果,确保在不同的AC控制下切换时不会断开链接。 为了实现AC/AP漫游,需要对拓扑进行相关配置。可以根据实验拓扑图来进行相应的设置。 以设置vlan为例,操作步骤如下: 1. 进入Switch_1设备的命令行界面。 2. 使用命令sysname Switch_1来设置设备名称。 3. 使用命令vlan batch 100来创建vlan100。 4. 进入GigabitEthernet0/0/1端口,使用命令port link-type trunk来修改端口模式为trunk。 5. 使用命令port trunk pvid vlan 100来修改端口默认vlan为vlan100,默认是vlan1。 6. 使用命令port trunk allow-pass vlan 100来设置允许vlan100通过。 7. 同样的步骤,将GigabitEthernet0/0/2端口也进行相应的配置。 8. 使用命令return退出配置模式。 另外,还可以根据需要设置其他vlan,并进行相应的配置。 以上是关于ENSP AC/AP漫游的简要说明和配置示例。具体操作步骤可以根据实际需求和拓扑来进行相应的设置和调整。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* *2* [华为ensp ac漫游-二层跨ac漫游](https://blog.csdn.net/h320758724/article/details/124518069)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 50%"] - *3* [华为无线enspac三层漫游](https://blog.csdn.net/h320758724/article/details/125108098)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 50%"] [ .reference_list ]

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值