Steps

Description

 

One steps through integer points of the straight line. The length of a step must be nonnegative and can be by one bigger than, equal to, or by one smaller than the length of the previous step.

What is the minimum number of steps in order to get from x to y? The length of the first and the last step must be 1.

Input and Output 

Input consists of a line containing n, the number of test cases. For each test case, a line follows with two integers:    0$ \le$x$ \le$y < 231. For each test case, print a line giving the minimum number of steps to get from x to y.   

Sample Input 

3
45 48
45 49
45 50

Sample Output 

3
3
4



 事实证明,能完全理解懂题,还是基本无难度的。

这个题重点每步梯度不大于1;

所以可以1234……n……4321,中找到恰好大于长度的点,然后注意后续的分类讨论。

#include <stdio.h>
#include <math.h>

int main()
{
    int K = 0;
    int a = 0,b = 0,len = 0;
    int n = 0,i = 0,sum = 0;
    int st = 0,tmp = 0;
    scanf ("%d",&K);

    while (K--)
    {
        i = 1;
        sum  = 0;
        scanf("%d%d",&a,&b);
        len = fabs (a - b);

        if (len == 0)
        {
            printf ("0\n");
            continue;
        }

        while (sum * 2 < len)
        {
            sum += i;
            i++;
        }
        i--;
        st = 2 * i - 1;
        sum = sum * 2 - i;

        if (sum < len)
            st++;


        printf ("%d\n",st);
    }
    return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值