数字三角形问题

1.问题描述

数字三角形问题。如下图是一个数字三角形宝塔。数字三角形中的数字为不超过100的正整数。现规定从最顶层走到最底层,每一步可沿左斜线或右斜线向下走。假设三角形行数<=100,编程求解从最顶层到最底层的一条路径,使得沿着该路径所经过的数字总和最大,输出最大值。

2.例题

The Triangle

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 4
描述

7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

输入
Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.
输出
Your program is to write to standard output. The highest sum is written as an integer.
样例输入
5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5
样例输出
30

3.解题思路

使用动态规划方法:按三角形的行划分阶段,若行数为n,则可把问题看做一个n-1个阶段的决策问题。先求出第n-1阶段(第n-1行上各点)到第n行的最大和,再依次求出第n-2阶段,第n-3阶段。。。。。。(起始点)各决策点至第n行的最佳路径。

以样例为例

动态规划自低向上解题


4.代码

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
using namespace std;
int max(int a,int b)
{
    return a > b? a : b;
}
int main()
{
    int n;
    while(cin>>n)
    {
        int a[n][n];
        for(int i = 0; i < n; i++)
        {
            for(int j = 0; j <= i; j++)
            {
                cin>>a[i][j];
            }
        }
        for(int i = n - 2; i >= 0; i--)
        {
            for(int j = 0; j <= i; j++)
                a[i][j] = a[i][j]+ max(a[i+1][j],a[i+1][j+1]);
        }
        cout<<a[0][0]<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值