The 3n + 1 Problem


Consider the following algorithm to generate a sequence of numbers. Start with an integer n. If
n is even, divide by 2. If n is odd, multiply by 3 and add 1. Repeat this process with the new value
of n, terminating when n = 1. For example, the following sequence of numbers will be generated for
n = 22:
22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1
It is conjectured (but not yet proven) that this algorithm will terminate at n = 1 for every integer n.
Still, the conjecture holds for all integers up to at least 1, 000, 000.
For an input n, the cycle-length of n is the number of numbers generated up to and including the
1. In the example above, the cycle length of 22 is 16. Given any two numbers i and j, you are to
determine the maximum cycle length over all numbers between i and j, including both endpoints.
Input
The input will consist of a series of pairs of integers i and j, one pair of integers per line. All
integers will be less than 1,000,000 and greater than 0.
Output
For each pair of input integers i and j, output i, j in the same order in which they appeared in
the input and then the maximum cycle length for integers between and including i and j. These three
numbers should be separated by one space, with all three numbers on one line and with one line of
output for each line of input.
Sample Input
1 10
100 200
201 210
900 1000
Sample Output
1 10 20
100 200 125
201 210 89

900 1000 17


这题简单,直接写代码。。。。。。。。。。。。

#include <iostream>
using namespace std;
long m(long n);
int main()
{
    long i, j, t, n, swap1;
    while(cin >> i >> j)
    {
        n = 0;
        cout << i << " " << j << " ";


        if( i > j)
        {
            swap1 = i;
            i = j;
            j = swap1;
        }
        for(t = i; t <= j; t ++ )
            if( m(t) >= n)
                n = m(t);
        cout << n <<endl;
    }
    return 0;
}


long m(long n)
{
    int i = 1;
    while(n > 1)
    {
        if( n % 2 == 0)
            n /= 2;
        else
            n = 3 * n + 1;
        i ++ ;
    }
    return i;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

一枚码农404

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值