1099. Build A Binary Search Tree (30)
标签: PAT 解题报告
A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:
The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (<=100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format “left_index right_index”, provided that the nodes are numbered from 0 to N-1, and 0 is always the root. If one child is missing, then -1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.
Output Specification:
For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.
Sample Input:
9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42
Sample Output:
58 25 82 11 38 67 45 73 42
这题是9月4日的模拟考的题目,当时没做出来.其实很简单,只不过因为实习了一个暑假,数据结构的一些东西已经忘得精光了,开学又是实验周,一点时间都抽不出来去复习,感觉这次的考试凶多吉少.
废话不多说,下面还是继续写一下这个题目.
题目的意思主要就是给定一个二叉树和一个序列,让我们写程序把这个序列填充为一个二叉搜索树.并且按照层序输出.
难点在于怎么处理输入,根据输入构造出相应的二叉树的结构.
二叉树的结构构造好后,就可以用中序遍历将数据填充进去.
我自己第一次写的代码没有提交通过,主要是因为错误理解了题意.我以为节点出现的顺序是按照顺序的,但是实际上并不是这样.所以提交失败.另外由于不知道怎么在递归中将数据填充进去,后来看了别人的解法才写出来.
下面贴一下看了别人的解法之后写出来的AC代码.
#include <iostream>
#include <algorithm>
#include <queue>
using namespace std;
int Left[105];
int Right[105];
int a[105];
int b[105];
void DFS(int now ,int &x){
if(now < 0)
return;
DFS(Left[now],x);
b[now] = a[x++];
DFS(Right[now],x);
}
int main(){
#ifndef ONLINE_JUDGE
freopen("data.in","r",stdin);
freopen("data.out","w",stdout);
#endif
int N ;
cin >> N;
for(int i = 0; i < N ; i ++){
cin >> Left[i] >> Right[i];
}
for(int i = 0; i < N ; i ++){
cin >> a[i];
}
sort(a,a+N);
int n = 0;
DFS(0,n);
queue<int> q;
q.push(0);
vector<int> answer;
while(!q.empty()){
int node = q.front();
q.pop();
answer.push_back(b[node]);
if(Left[node] != -1) q.push(Left[node]);
if(Right[node] != -1) q.push(Right[node]);
}
for(int i = 0; i < answer.size(); i ++){
cout << answer[i] << (i == answer.size() - 1?"":" ");
}
return 0;
}