poj 2524 Ubiquitous Religions——我感觉是并查集(分类是分治)

Ubiquitous Religions
Time Limit: 5000MS
Memory Limit: 65536K
Total Submissions: 22819
Accepted: 11252

Description

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in. 

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

Input

The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.

Output

For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

Sample Input

10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0

Sample Output

Case 1: 1
Case 2: 7

Hint

Huge input, scanf is recommended.

Source


这个题好像在我们sdutoj上见过,只是类似,其实对这类题型很敏感,就是并查集,并查集有个很好的优化叫压缩路径,不过本题压缩路径好像不好用,因为压缩路径只保证路径深度<=3,是个不确定数,但本题要求是输出有多少个不同的宗教,必定会用到统计,既然深度不确定,那么统计可能会错,就不如不压缩了,反正时间给了五秒,估计够用,本题思路是用并查集连接点,统计(s[i]==i,I<=n)满足这个式子的个数......如果你还有疑惑为什么这样做,就去看看我的并查集吧...http://blog.csdn.net/codeblf2/article/details/19568615。

#include <stdio.h>
#include <stdlib.h>
#include <string.h>

int s[50010];

int find1(int x)//并查集的查找函数
{
    int r=x,q;
    while(x!=s[x])
    {
        x=s[x];
    }
//    while(x!=s[r])
//    {
//        q=s[r];
//        s[r]=x;
//        r=q;
//    }//这是压缩路径代码  被我注释掉了
    return x;
}

void creat(int m)
{
    int x,y,i,fx,fy;
    for(i=0;i<m;i++)
    {
        scanf("%d%d",&x,&y);
        fx=find1(x);
        fy=find1(y);
        if(fx!=fy)
        {
            s[fx]=fy;
        }//并查集的连接模块
    }
}

int main()
{
    int i,n,m,js,c=0;
    while(scanf("%d%d",&n,&m),n&&m)
    {
        js=0;
        for(i=1;i<=n;i++)
        {
            s[i]=i;
        }//这个初始化,必须有
        creat(m);
        for(i=1;i<=n;i++)
        {
           if(s[i]==i)
           {
               js++;
           }
        }//按上面我说的规则进行统计
        printf("Case %d: %d\n",++c,js);
    }
    return 0;
}







评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值