UVA 152 ---Tree's a Crowd 模拟

15 篇文章 0 订阅

Tree's a Crowd
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %ll 

Description

Download as PDF


 Tree's a Crowd 

Dr William Larch, noted plant psychologist and inventor of the phrase ``Think like a tree--Think Fig'' has invented a new classification system for trees. This is a complicated system involving a series of measurements which are then combined to produce three numbers (in the range [0, 255]) for any given tree. Thus each tree can be thought of as occupying a point in a 3-dimensional space. Because of the nature of the process, measurements for a large sample of trees are likely to be spread fairly uniformly throughout the whole of the available space. However Dr Larch is convinced that there are relationships to be found between close neighbours in this space. To test this hypothesis, he needs a histogram of the numbers of trees that have closest neighbours that lie within certain distance ranges.

Write a program that will read in the parameters of up to 5000 trees and determine how many of them have closest neighbours that are less than 1 unit away, how many with closest neighbours 1 or more but less than 2 units away, and so on up to those with closest neighbours 9 or more but less than 10 units away. Thus if tex2html_wrap_inline26 is the distance between the i'th point and its nearest neighbour(s) and tex2html_wrap_inline28 , with j and k integers and k = j+1, then this point (tree) will contribute 1 to the j'th bin in the histogram (counting from zero). For example, if there were only two points 1.414 units apart, then the histogram would be 0, 2, 0, 0, 0, 0, 0, 0, 0, 0.

Input and Output

Input will consist of a series of lines, each line consisting of 3 numbers in the range [0, 255]. The file will be terminated by a line consisting of three zeroes.

Output will consist of a single line containing the 10 numbers representing the desired counts, each number right justified in a field of width 4.

Sample input

10 10 0
10 10 0
10 10 1
10 10 3
10 10 6
10 10 10
10 10 15
10 10 21
10 10 28
10 10 36
10 10 45
0 0 0

Sample output

   2   1   1   1   1   1   1   1   1   1


一开始没看懂题。。。。。。


#include <stdio.h>
#include <string.h>
#include  <math.h>

double s[5010][3];
int jg[15];

int main()
{
    int k = 0;
    memset(jg,0,sizeof(jg));
    while(scanf("%lf%lf%lf",&s[k][0],&s[k][1],&s[k][2]))
    {
        if(s[k][0] == 0&& s[k][1] == 0 && s[k][2] == 0)
            break;
        k++;
    }
    for(int i = 0;i < k;i++)
    {
        int inf = 99999999;
        for(int j = 0;j < k;j++)
        {
            if(i != j)
            {
                int tmp = (int)sqrt(pow(s[i][0]-s[j][0],2) + pow(s[i][1]-s[j][1],2) + pow(s[i][2]-s[j][2],2));
                if(inf > tmp)
                    inf = tmp;
            }
        }
        if(inf < 10)
            jg[inf]++;
    }
    for(int i = 0;i < 10;i++)
    {
        printf("%4d",jg[i]);
    }
    printf("\n");
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值