HDU 3833 YY's new problem 哈希

6 篇文章 0 订阅

YY's new problem

Time Limit: 12000/4000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 4675    Accepted Submission(s): 1324


Problem Description
Given a permutation P of 1 to N, YY wants to know whether there exists such three elements P[i1], P[i2], P[i3] that 
P[i1]-P[i2]=P[i2]-P[i3], 1<=i1<i2<i3<=N.
 

Input
The first line is T(T<=60), representing the total test cases.
Each test case comes two lines, the former one is N, 3<=N<=10000, the latter is a permutation of 1 to N.
 

Output
For each test case, just output 'Y' if such i1, i2, i3 can be found, else 'N'.
 

Sample Input
  
  
2 3 1 3 2 4 3 2 4 1
 

Sample Output
  
  
N Y
 

Source


p1 - p2 = p2 - p3  可以得到2p2 = p1 + p3    ----> p2 = (p1 + p3) / 2,用哈希表记录整个输入的数的下标,当然,数组要从1开始,然后枚举p1和p3,求p2,看看p2是否存在并且p2的下标是否大于p1且小于p3,如果成立就是Y,否则就是N。。。。

#include <stdio.h>
#include <string.h>

int s[10010];
int hs[10010];

int main()
{
    int t,n;
    while(~scanf("%d",&t))
    {
        while(t--)
        {
            scanf("%d",&n);
            memset(hs,0,sizeof(hs));
            for(int i = 1; i <= n; i++)
            {
                scanf("%d",&s[i]);
                hs[s[i]] = i;
            }
            int flag = 0;
            for(int i = 1; i <= n - 2; i++)
            {
                for(int j = n; j >= i + 1; j--)
                {
                    int a = s[i] + s[j];
                    if(!(a & 1) && hs[a >> 1] && hs[a >> 1] > i && hs[a >> 1] < j)//if(a%2==0&&hs[a/2]&&hs[a/2]>i&&hs[a/2]<j)
                    {
                      //  printf("%d %d\n",i,j);
                        flag = 1;
                        break;
                    }
                }
                if(flag)
                    break;
            }
            if(flag)
                printf("Y\n");
            else
                printf("N\n");
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值