POJ 1094 Sorting It All Out ——拓扑排序(有点坑)

Sorting It All Out
Time Limit: 1000MS
Memory Limit: 10000K
Total Submissions: 28628
Accepted: 9896

Description

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.

Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.

Output

For each problem instance, output consists of one line. This line should be one of the following three: 

Sorted sequence determined after xxx relations: yyy...y. 
Sorted sequence cannot be determined. 
Inconsistency found after xxx relations. 

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence. 

Sample Input

4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

Sample Output

Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.

Source




错了好几遍不知道自己怎么错的,看了看讨论,才知道需要每输入一组数据就要排序一次,只能说真坑。。。。。


#include <stdio.h>
#include <string.h>

bool mp[27][27];
int deg[27];
int s[27];
int num;

int toposort(int n)
{
    int tmp[27],flag = 2;
    memset(s,0,sizeof(s));
    for(int i = 1;i <= n;i++)
        tmp[i] = deg[i];
    for(int i = 1;i <= n;i++)
    {
        int js = 0,bj = 0;
        for(int j = 1;j <= n;j++)
        {
            if(!tmp[j])
            {
                js++;
                bj = j;
            }
        }
        if(!js)
            return 0;//有环
        if(js > 1)
            flag = 1;//有待于进一步排序
        s[i] = bj;
        tmp[bj] = -1;
        for(int j = 1;j <= n;j++)
        {
            if(mp[bj][j])
            {
                tmp[j]--;
            }
        }
    }
    return flag;
}

int main()
{
    int n,m,bj,fh;
    char sr[10];
    while(scanf("%d%d",&n,&m),n || m)
    {
        num = 0;
        bool flag = true;
        memset(mp,false,sizeof(mp));
        memset(deg,0,sizeof(deg));
        for(int i = 0;i < m;i++)
        {
            scanf("%s",sr);
            if(!flag)
                continue;
            int zh1 = sr[0] - 'A' + 1;
            int zh2 = sr[2] - 'A' + 1;
            if(!mp[zh1][zh2])
            {
                mp[zh1][zh2] = true;
                deg[zh2]++;
            }
            fh = toposort(n);
            if(fh == 0 || fh == 2)
            {
                bj = i + 1;
                flag = false;
            }
        }
        if(fh == 0)
        {
            printf("Inconsistency found after %d relations.\n",bj);
        }
        else if(fh == 2)
        {
            printf("Sorted sequence determined after %d relations: ",bj);
            for(int i = 1;i <= n;i++)
                printf("%c",char(s[i] + 'A' - 1));
            printf(".\n");
        }
        else if(fh == 1 && flag)
        {
            printf("Sorted sequence cannot be determined.\n");
        }

    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值