POJ 1094 Sorting It All Out 拓扑排序

题目描述:

Description

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.
Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character “<” and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.
Output

For each problem instance, output consists of one line. This line should be one of the following three:

Sorted sequence determined after xxx relations: yyy…y.
Sorted sequence cannot be determined.
Inconsistency found after xxx relations.

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy…y is the sorted, ascending sequence.
Sample Input

4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

Sample Output

Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.

题目分析:

n个点,m个偏序关系,对每一个偏序关系以及之前输入的偏序关系,进行拓扑排序,若能拓扑排序并且只有一种排序情况,输出;若出现环,也输出;若在所有数据输入之后无法判断,也输出。
这题与一般的拓扑排序题不一样的地方就是对每一组数据都要进行判断,开始的时候我在套模板出现了很多问题,因为在某几条数据输入之前,有些点的偏序关系没有确定,所以不能当做入度为0的点进行处理。

代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;
const int MAXN=30;
int n,m;
int graph[MAXN][MAXN],indegree[MAXN],seq[MAXN];

int toposort()
{
    queue<int> q;
    int in[MAXN];
    for(int i=0; i<n; i++)
    {
        in[i]=indegree[i];
        if (in[i]==0) q.push(i);
    }
    int k=0;
    bool res=false;
    while(!q.empty())
    {
        if(q.size()>1) res=true;
        int u=q.front();
        q.pop();
        seq[k++]=u;
        for(int i=0; i<n; i++)
        {
            int v=i;
            if (graph[u][v]==1)
            {
                in[v]--;
                if (in[v]==0) q.push(v);
            }
        }
    }
    if(k!=n)return -1;//存在有向环,总之不能进行拓扑排序
    if(res)return 1;//可以进行拓扑排序,有多种情况,seq数组是其中一种序列
    return 0;//可以进行拓扑排序,并且只有唯一一种方式,seq数组即是排序完好的序列
}

int main()
{
    while(scanf("%d%d",&n,&m) && (n||m))
    {
        bool determined=0;
        bool inconsistency=0;
        char str[5];
        memset(graph,0,sizeof(graph));
        memset(indegree,0,sizeof(indegree));
        for(int i=1;i<=m;i++)
        {
            scanf("%s",str);
            int u=str[0]-'A';
            int v=str[2]-'A';
            if(!determined && !inconsistency)
            {
                if(graph[v][u]==1)//存在反向边,则发现矛盾
                {
                    inconsistency=1;
                    printf("Inconsistency found after %d relations.\n",i);
                    continue;
                }
                if(graph[u][v]==0)
                {
                    graph[u][v]=1;
                    indegree[v]++;
                }
                int res=toposort();//toposort
                if(res==0)//序列能够被唯一确定
                {
                    printf("Sorted sequence determined after %d relations: ",i);
                    for(int j=0; j<n; j++)
                        printf("%c",seq[j]+'A');
                    printf(".\n");
                    determined=1;
                }
                else if(res==-1)//不能拓扑排序,即有环,发现矛盾
                {
                    printf("Inconsistency found after %d relations.\n",i);
                    inconsistency=1;
                }
            }
        }
        if(!determined && !inconsistency)//既没有唯一确定,也没发现矛盾(有环),即不能确定
            printf("Sorted sequence cannot be determined.\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值