All in All
Time Limit: 1000MS | Memory Limit: 30000K | |
Total Submissions: 28812 | Accepted: 11931 |
Description
You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.
Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.
Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.
Input
The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.
Output
For each test case output "Yes", if s is a subsequence of t,otherwise output "No".
Sample Input
sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter
Sample Output
Yes
No
Yes
No
Source
简单模式匹配:
#include <stdio.h>
#include <string.h>
char s1[100010],s2[100010];
int main()
{
while(~scanf("%s%s",s1,s2))
{
char *p = s1,*q = s2;
while(*p != '\0' && *q != '\0')
{
if(*p == *q)
{
p++;
}
q++;
}
if(*p == '\0')
printf("Yes\n");
else
printf("No\n");
}
return 0;
}