【白书之路】 10340 All in All 判断子串

10340 All in All

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in
detail how the strings are generated and inserted into the original message. To validate your method,
however, it is necessary to write a program that checks if the message is really encoded in the final
string.
Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove
characters from t such that the concatenation of the remaining characters is s.
Input
The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII
characters separated by whitespace. Input is terminated by EOF.
Output
For each test case output, if s is a subsequence of t.
Sample Input
sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter
Sample Output
Yes
No
Yes
No


判断一个字符串是否是另一个字符串的字串,这里采用双指针遍历的方法,用两个指针指向两个字符串,如果所指字符相同,则都向前加1,否则,主串指针向前加1,最后判断字串指针所指字符是否是'\0',如果是,说明主串中包含字串。

这题有一个大坑,题目中没有说明字符串长度,结果设小了,RE到死,还WA了好几次,最后,直接设个大的,事实证明,在不知道长度的情况下,尽量往大了设。

#include <iostream>
#include <stdio.h>
#include <string.h>
#define MAX 100005
using namespace std;

char s[MAX];
char t[MAX];
int p,q;


int main()
{
    while(~scanf("%s%s",s,t))
    {
        p=q=0;//指针初始化
        while(t[q]!='\0')//主串指针没有走到最后
        {
            if(s[p]==t[q])//所指字符相同
            {
                p++;
                q++;
            }
            else//所指字符不同
                q++;
        }
        if(s[p]=='\0')//字串指针指向最后
            printf("Yes\n");
        else
            printf("No\n");
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值