HDU 1247 Hat’s Words 字典树

Hat’s Words

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8778    Accepted Submission(s): 3151


Problem Description
A hat’s word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.
You are to find all the hat’s words in a dictionary.
 

Input
Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 50,000 words.
Only one case.
 

Output
Your output should contain all the hat’s words, one per line, in alphabetical order.
 

Sample Input
  
  
a ahat hat hatword hziee word
 

Sample Output
  
  
ahat hatword
 

Author
戴帽子的

#include <stdio.h>
#include <string.h>

struct node
{
    bool flag;
    node *next[26];
    node()
    {
        flag = false;
        memset(next,0,sizeof(next));
    }
};

char mp[50001][110];
int mplen[50001];
int stk[50001];

void build(node *&head,char str[],int len)
{
    node *p = head,*q;
    for(int i = 0; i < len; i++)
    {
        int zh = str[i] - 'a';
        if(p->next[zh])
        {
            p = p->next[zh];
        }
        else
        {
            q = new node;
            p->next[zh] = q;
            p = q;
        }
    }
    p->flag = true;
}

bool nfind(node *&head,char str[],int len)
{
    node *p = head;
    int tp = 0;
    for(int i = 0; i < len; i++)
    {
        int zh = str[i] - 'a';
        if(p->next[zh])
            p = p->next[zh];
        if(p->flag && i + 1 < len)
            stk[tp++] = i + 1;//一个单词可能有多个组成,或是一个单词遍历的时候,会有多个true在里面,这里都记录下来
    }
    while(tp)
    {
        bool flag = true;
        int i = stk[tp - 1];
        tp--;
        p = head;
        for(; i < len; i++)
        {
            int zh = str[i] - 'a';
            if(p->next[zh])
            {
                p = p->next[zh];
            }
            else
            {
                flag = false;//注意这个地方,当当前从i开始不能找到,并不代表栈里面所有的都找不到
                break;
            }
        }
        if(p->flag && flag)
            return true;
    }
    return false;
}

int main()
{
    node *head = new node;
    int k = 0;
    while(~scanf("%s",mp[k]))
    {
        mplen[k] = strlen(mp[k]);
        build(head,mp[k],mplen[k]);
        k++;
    }
    for(int i = 0; i < k; i++)
    {
        if(nfind(head,mp[i],mplen[i]))
            printf("%s\n",mp[i]);
    }
    return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值