hdu1247 Hat’s Words 字典树


Problem Description
A hat’s word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.
You are to find all the hat’s words in a dictionary.
 

Input
Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 50,000 words.
Only one case.
 

Output
Your output should contain all the hat’s words, one per line, in alphabetical order.
 

Sample Input
  
  
a ahat hat hatword hziee word
 

Sample Output
  
  
ahat hatword 题意:输入一连串的 单词 组成的字典 输出字典中由两个其他单词组成的单词 构造字典树即可。。。 代码:
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
struct node{
    int last;                  //last用来判断是否为一个单词的最后一个字母
    struct node *next[26];
    node()                 //构造函数
    {
        last=0;                    
        memset(next,NULL,sizeof(next));
    }
}*root;
char str[50005][20];
int s=0;
void insert_str(char *s)        //构造字典树
{
    node *p=root;
    while(*s!='\0')
    {
        int d=*s-'a';
        if(p->next[d]==NULL)
        {
            p->next[d]= new node();
            p=p->next[d];
        }
        else
            p=p->next[d];
        s++;
    }
    p->last=1;
    return ;
}
int find2(char *s)
{
    node *p=root;
    while(*s!='\0')
    {
        int d=*s-'a';
        p=p->next[d];
        if(p!=NULL)
        {
            if(p->last==1&&*(s+1)=='\0')     //当后半部分为单词 且没有后缀
                return 1;
            s++;
        }
        else
            return 0;
    }
    return 0;               //重要  返回可能默认为1
}
int find(char *s)
{
    node *p=root;
    while(*s!='\0')
    {
        int d=*s-'a';
        p=p->next[d];
        if(p!=NULL)
        {
            if(p->last==1&&find2(s+1))    //当已经确认前半部分为一个单词 再确认后半部分是否为单词
                return 1;
            s++;
        }
        else
            return 0;
    }
    return 0;
}
int main()
{
    int i,j;
    root=new node();                 //  根节点
    while(scanf("%s",str[s])!=EOF)
    {
        insert_str(str[s]);
        s++;
    }
    for(i=0;i<s;i++)
    {
        if(find(str[i]))
            cout<<str[i]<<endl;
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值