poj2155--Matrix(二维树状数组)

Matrix
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 18021 Accepted: 6755

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N). 

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions. 

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2). 
2. Q x y (1 <= x, y <= n) querys A[x, y]. 

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case. 

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above. 

Output

For each querying output one line, which has an integer representing A[x, y]. 

There is a blank line between every two continuous test cases. 

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1

Source

POJ Monthly,Lou Tiancheng
二维的树状数组,一般的修改和查询
对二维的树状数组的修改
void add(int i,int j,int d,int n)
{
    int x , y ;
    for(x = i ; x <= n ; x += lowbit(x))
        for(y = j ; y <= n ; y += lowbit(y))
            c[x][y] += d;
}
查询
int sum(int i,int j)
{
    int a = 0 , x , y ;
    for(x = i ; x >= 0 ; x -= lowbit(x))
        for(y = j ; y >= 0 ; y -= lowbit(y))
            a += c[x][y] ;
    return a ;
}
题意:给出n*n的矩阵,矩阵中的值只能为0或者1,初始值全部是0,C x1 y1 x2 y2 表示在(x1,y1)和(x2,y2)围成的矩形中的所有值变换 ;Q x y 查询该点当前的值,也可以认为是统计该点经过了几次的变化;
在这个题中树状数组由后向前更新,每一个点的值表示由该点向前的所有点变换的次数
对于C的操作
首先 将(1,1)到(x2,y2)的所有点+1 ,代表有该点向前的矩形中的变化次数均+1;再由 (x1-1,y2)(x2,y1-1)均-1, (x1-1,y1-1)+1,平衡掉多操作的点,那么当计算该点变换次数时,由该点向后累加,得到的总和就是该点的变换次数,如果是奇数代表1,否则是0.

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int c[1010][1010] ;
int lowbit(int x)
{
    return x & -x ;
}
void add(int i,int j,int d)
{
    int x , y ;
    for(x = i ; x > 0 ; x -= lowbit(x))
        for(y = j ; y > 0 ; y -= lowbit(y))
            c[x][y] += d;
}
int sum(int i,int j,int n)
{
    int a = 0 , x , y ;
    for(x = i ; x <= n ; x += lowbit(x))
        for(y = j ; y <= n ; y += lowbit(y))
            a += c[x][y] ;
    return a ;
}
int main()
{
    int t , tt , i , j , n , m , x1 , y1 , x2 , y2 ;
    char ch ;
    scanf("%d", &t);
    for(tt = 1 ; tt <= t ; tt++)
    {
        scanf("%d %d", &n, &m);
        memset(c,0,sizeof(c));
        while(m--)
        {
            getchar();
            scanf("%c", &ch);
            if( ch == 'C' )
            {
                scanf("%d %d %d %d", &x1, &y1, &x2, &y2);
                add(x2,y2,1);
                add(x1-1,y2,-1);
                add(x2,y1-1,-1);
                add(x1-1,y1-1,1);
            }
            else
            {
                scanf("%d %d", &x1, &y1);
                printf("%d\n", sum(x1,y1,n)%2 );

            }
        }
        if(tt != t)
            printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值