poj-2155-Matrix(树状数组 || 线段树)

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).
We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using “not” operation (if it is a ‘0’ then change it into ‘1’ otherwise change it into ‘0’). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.
1.C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2).
2.Q x y (1 <= x, y <= n) querys A[x, y].

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case.
The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format “Q x y” or “C x1 y1 x2 y2”, which has been described above.

Output

For each querying output one line, which has an integer representing A[x, y].
There is a blank line between every two continuous test cases.

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1


树状数组

二维的写起来很方便,两重循环。
如果是要修改(x1,y1) - (x2,y2)的矩形区域。
那么可以在(x1,y1) 出加1,在(x2+1,y1)处加1,在(x1,y2+1)处加1,在(x2+1,y2+1)处加1

#include <iostream> 
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm> 
#define N 1005
using namespace std;
int c[N][N], n;
void add(int x, int y, int d)
{
    for (int i = x; i <= n; i += i&-i)
        for (int j = y; j <= n; j+=j&-j)
            c[i][j] += d;
}
int sum(int x, int y)
{
    int ans = 0;
    for (int i = x ; i > 0; i-=i&-i)
        for (int j = y; j > 0; j-=j&-j)
            ans += c[i][j];
    return ans;
}
int main()
{
#ifndef ONLINE_JUDGE
    freopen("1.txt", "r", stdin);
#endif
    int T, X, x, xx, y, yy;
    char cc;
    cin >> X;
    while(X--)
    {
        cin >> n >> T;
        memset(c, 0, sizeof(c));
        while(T--)
        {
            cin >> cc;
            if (cc == 'C')
            {
                cin >> x >> y >> xx >> yy;
                add(x, y, 1);
                add(xx+1, y, 1);
                add(x, yy+1, 1);
                add(xx+1, yy+1, 1);
            }
            else
            {
                cin >> x >> y;
                cout << (sum(x, y)&1) << endl;
            }
        }
        if (X)  cout << endl;
    }
    return 0;
}

线段树

#include <iostream>
#include <iomanip>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <string>
#include <cmath>
#include <map> 
#include <algorithm>
#define N 1005
#define ll long long
#define mod 9901
const int mm = 1000000007;
int n, num, x, y, xx, yy;;
bool tree[N<<2][N<<2];
using namespace std;
void editY(int kx, int ky, int yl, int yr)
{
    if (y <= yl && yy >= yr)
    {
        tree[kx][ky] ^= 1;
        return ;
    }
    int mid = (yl+yr)>>1;
    if (y <= mid)   editY(kx, ky<<1, yl, mid);
    if (yy > mid)   editY(kx, ky<<1|1, mid+1, yr);
}
void editX(int kx, int xl, int xr)
{
    if (x <= xl && xx >= xr)
    {
        editY(kx, 1, 1, n);
        return ;
    }
    int mid = (xl+xr)>>1;
    if (x <= mid)   editX(kx<<1, xl, mid);
    if (xx > mid)   editX(kx<<1|1, mid+1, xr);
}
void queryY(int kx, int ky, int yl, int yr)
{
    if (tree[kx][ky])   num++;
    if (yl==yr) return ;
    int m = (yl+yr)>>1;
    if (y <= m) queryY(kx, ky<<1, yl, m);
    else    queryY(kx, ky<<1|1, m+1, yr);
}
void queryX(int kx, int xl, int xr)
{
    queryY(kx, 1, 1, n);
    if (xl == xr)   return ;
    int m = (xl+xr)>>1;
    if (x <= m) queryX(kx<<1, xl, m);
    else    queryX(kx<<1|1, m+1, xr);
}
int main() 
{
#ifndef ONLINE_JUDGE
    freopen("1.txt", "r", stdin);
#endif
    ios::sync_with_stdio(false);
//  cin.tie(0);
    int i, j, X, T;
    char c;
    cin >> X;
    while(X--)
    {
        memset(tree, 0, sizeof(tree));
        cin >> n >> T;
        while(T--)
        {
            cin >> c;
            if (c == 'C')
            {
                cin >> x >> y >> xx >> yy;
                editX(1, 1, n);
            }
            else
            {
                cin >> x >> y;
                num = 0;
                queryX(1, 1, n);
                cout << (num&1) << endl;
            }
        }   
        if (X)  cout << endl;
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值