测试赛A - Colored Sticks(并查集+字典树+欧拉回路)

A - Colored Sticks
Time Limit:5000MS     Memory Limit:128000KB     64bit IO Format:%I64d & %I64u
Submit   Status

Description

You are given a bunch of wooden sticks. Each endpoint of each stick is colored with some color. Is it possible to align the sticks in a straight line such that the colors of the endpoints that touch are of the same color?

Input

Input is a sequence of lines, each line contains two words, separated by spaces, giving the colors of the endpoints of one stick. A word is a sequence of lowercase letters no longer than 10 characters. There is no more than 250000 sticks.

Output

If the sticks can be aligned in the desired way, output a single line saying Possible, otherwise output Impossible.

Sample Input

blue red
red violet
cyan blue
blue magenta
magenta cyan

Sample Output

Possible

Hint

Huge input,scanf is recommended.
使用字典树来给每个颜色定一个序号,并统计出现的次数,使用并查集判断是否全部的点联通,在用欧拉回路,看整个图是不是可以一次走完,
判断方法,如果奇数度数的点为0或2个,那么一定可以走通

#include <cstdio>
#include <cstring>
int p[520000] , top , q[520000];
struct node{
    int flag ;
    node *next[27] ;
} *head;
node *newnode()
{
    node *p = new node ;
    p->flag = 0;
    for(int i = 0 ; i < 27 ; i++)
        p->next[i] = NULL ;
    return p;
}
int gettree(node *head,char *s)
{
    int i , l = strlen(s) ;
    node *p = head ;
    for(i = 0 ; i < l ; i++)
    {
        int k = s[i] - 'a' ;
        if(p->next[k]==NULL)
            p->next[k] = newnode();
        p = p->next[k] ;
    }
    if( p->flag == 0 )
        p->flag = top++ ;
    return p->flag ;
}
int f(int x)
{
    int r , k , l ;
    r = x ;
    while( r != p[r] )
        r = p[r] ;
    k = x ;
    while( k != r )
    {
        l = p[k] ;
        p[k] = r ;
        k = l ;
    }
    return r ;
}
void add(int u,int v)
{
    u = f(u) ;
    v = f(v) ;
    if( u != v )
        p[u] = v ;

}
char s1[11] , s2[11] ;
int main()
{
    int i , n , k1 , k2 ;
    memset(q,0,sizeof(q));
    head = newnode() ;
    for(i = 0 ; i <= 520000 ; i++)
        p[i] = i ;
        top = 1 ;
    while( scanf("%s %s", s1, s2 ) !=EOF )
    {
        k1 = gettree(head,s1);
        k2 = gettree(head,s2);
        q[k1]++ ;
        q[k2]++ ;
        add(k1,k2) ;
    }
    int k = f(1) ;
    for(i = 2 ; i < top ; i++)
        if( k != f(i) )
            break;
    if( i < top )
        printf("Impossible\n");
    else
    {
        int ji = 0 ;
        for(i = 1 ; i < top ; i++)
            if( q[i]%2 )
                ji++ ;
        if(ji ==0 || ji == 2)
            printf("Possible\n");
        else
            printf("Impossible\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值