poj1703--Find them, Catch them(并查集应用)

Find them, Catch them
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 32073 Accepted: 9890

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)  

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:  

1. D [a] [b]  
where [a] and [b] are the numbers of two criminals, and they belong to different gangs.  

2. A [a] [b]  
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.  

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

Source

题目大意,给出n个人m个操作,A操作问两个人是不是在同一个集合里,D操作代表两个人不在一个集合里。
 
开一个数组d,d[i] = j,代表i所属的集合和j的集合对立,用并查集不断更新它就可以了
 
 
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define maxn 110000
int c[maxn] , d[maxn] ;
int find1(int x)
{
    if( c[x] != x )
    {
        c[x] = find1(c[x]) ;
        d[x] = d[ c[x] ] ;
    }
    return c[x] ;
}
int main()
{
    int t , n , m , i , j ;
    char str[10] ;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d %d", &n, &m);
        for(i = 1 ; i <= n ; i++)
            c[i] = i ;
        memset(d,-1,sizeof(d));
        while(m--)
        {
            int a , b , x , y , xx , yy ;
            scanf("%s %d %d", str, &a, &b);
            x = find1(a) ;
            y = find1(b) ;
            if( str[0] == 'D' )
            {
                if(d[x] == -1 && d[y] == -1)
                {
                    d[a] = b ; d[b] = a ;
                }
                else
                {
                    if( d[x] != -1 )
                    {
                        if( d[y] != -1 )
                        {
                            xx = d[y] ;
                            xx = find1(xx) ;
                            c[xx] = x ;
                            d[xx] = d[x] ;
                        }
                        c[y] = d[x] ;
                        d[y] = x ;

                    }
                    else
                    {
                        if( d[x] != -1 )
                        {
                            yy = d[x] ;
                            yy = find1(yy) ;
                            c[yy] = y ;
                            d[yy] = d[y] ;
                        }
                        c[x] = d[y] ;
                        d[x] = y ;
                    }
                }
            }
            else
            {
                if( x == y )
                    printf("In the same gang.\n");
                else if( d[x] == -1 || d[y] == -1 || d[x] != y || d[y] != x  )
                    printf("Not sure yet.\n");
                else if( d[x] == y || d[y] != x )
                    printf("In different gangs.\n");

            }
        }
    }
    return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值