zoj3329--One Person Game(概率dp第六弹:形成环的dp,带入系数,高斯消元)

One Person Game

Time Limit: 1 Second        Memory Limit: 32768 KB        Special Judge

There is a very simple and interesting one-person game. You have 3 dice, namely Die1Die2 and Die3Die1 has K1 faces. Die2 has K2 faces. Die3 has K3 faces. All the dice are fair dice, so the probability of rolling each value, 1 to K1K2K3 is exactly 1 / K1, 1 / K2 and 1 / K3. You have a counter, and the game is played as follow:

  1. Set the counter to 0 at first.
  2. Roll the 3 dice simultaneously. If the up-facing number of Die1 is a, the up-facing number of Die2 is b and the up-facing number of Die3 is c, set the counter to 0. Otherwise, add the counter by the total value of the 3 up-facing numbers.
  3. If the counter's number is still not greater than n, go to step 2. Otherwise the game is ended.

Calculate the expectation of the number of times that you cast dice before the end of the game.

Input

There are multiple test cases. The first line of input is an integer T (0 < T <= 300) indicating the number of test cases. Then T test cases follow. Each test case is a line contains 7 non-negative integers nK1K2K3abc (0 <= n <= 500, 1 < K1K2K3 <= 6, 1 <= a <= K1, 1 <= b <= K2, 1 <= c <= K3).

Output

For each test case, output the answer in a single line. A relative error of 1e-8 will be accepted.

Sample Input

2
0 2 2 2 1 1 1
0 6 6 6 1 1 1

Sample Output

1.142857142857143
1.004651162790698
 
题目大意:给出了k1,k2,k3三个筛子,当k1 == a k2 == b k3 == c时分数归零,否则累加,问当总和到n以上需要的次数期望
状态方程很好写,dp[i]代表由i到n以上需要的次数,dp[i] = ∑(p[j]*dp[i+j])+q*dp[0] + 1;p[j]代表掷出和为j的概率,q为归零的概率,但是为问题出现了,在状态方程中有dp[0]这是我们要求解的值。所以要带入系数dpa[],dpb[],dp[i] = dpa[i] + dpb[i]*dp[0] ;
最后求解出dp[0] = dpa[0] + dpb[0]*dp[0],可以解除dp[0];
dp[i] = dpa[i] + dpb[i]*dp[0] = ∑(p[j]*dp[i+j])+ q*dp[0]+1;
得到dpa[i] = ∑( p[j]*dpa[i+j] ) + 1 ;   dpb[i] = ∑( p[j]*dpb[i+j] ) + q ;
 
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
double p[20] , q , cnt ;
double dpa[600] , dpb[600] ;
int main()
{
    int t , n , m , i , j , k , l , k1 , k2 , k3 , a , b , c ;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d %d %d %d %d %d %d", &n, &k1, &k2, &k3, &a, &b, &c);
        memset(p,0,sizeof(p));
        memset(dpa,0,sizeof(dpa));
        memset(dpb,0,sizeof(dpb));
        p[a+b+c] = -1 ;
        cnt = 0 ;
        m = k1 + k2 + k3 ;
        for(i = 1 ; i <= k1 ; i++)
            for(j = 1 ; j <= k2 ; j++)
                for(k = 1 ; k <= k3 ; k++)
                {
                    p[i+j+k] += 1.0 ;
                    cnt += 1.0 ;
                }
        for(i = 3; i <= m ; i++)
            p[i] /= cnt ;
        q = 1.0 / cnt ;
        for(i = n ; i >= 0 ; i--)
        {
            dpa[i] = 1.0 ; dpb[i] = q ;
            for(j = 3 ; j <= k1+k2+k3 ; j++)
            {
                dpa[i] += p[j]*dpa[i+j] ;
                dpb[i] += p[j]*dpb[i+j] ;
            }
        }
        printf("%.10lf\n", dpa[0]/(1-dpb[0]));
    }
    return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值