(ZOJ 3329) One Person Game (概率DP)

There is a very simple and interesting one-person game. You have 3 dice, namely Die1Die2 and Die3Die1 has K1 faces. Die2 has K2 faces. Die3 has K3 faces. All the dice are fair dice, so the probability of rolling each value, 1 to K1K2K3 is exactly 1 / K1, 1 / K2 and 1 / K3. You have a counter, and the game is played as follow:

  1. Set the counter to 0 at first.
  2. Roll the 3 dice simultaneously. If the up-facing number of Die1 is a, the up-facing number of Die2 is b and the up-facing number of Die3 is c, set the counter to 0. Otherwise, add the counter by the total value of the 3 up-facing numbers.
  3. If the counter's number is still not greater than n, go to step 2. Otherwise the game is ended.

Calculate the expectation of the number of times that you cast dice before the end of the game.

Input

There are multiple test cases. The first line of input is an integer T (0 < T <= 300) indicating the number of test cases. Then T test cases follow. Each test case is a line contains 7 non-negative integers nK1K2K3abc (0 <= n <= 500, 1 < K1K2K3 <= 6, 1 <= a <= K1, 1 <= b <= K2, 1 <= c <= K3).

Output

For each test case, output the answer in a single line. A relative error of 1e-8 will be accepted.

Sample Input

2
0 2 2 2 1 1 1
0 6 6 6 1 1 1

Sample Output

1.142857142857143
1.004651162790698

 同样的扔色子问题,dp[i]代表到达i分数时距离游戏结束还可以扔的期望值,同样是倒推。

由于每个状态有概率能转化到初始状态,所以把每个状态的dp值用多项式来表达,即dp【i】=a*dp【0】+b;

从而将dp数组变成二维的。1位存常数,2位存dp【0】前的系数;

最后dp【0】=a*dp【0】+b;解出dp【0】即可;

一次过,爽~

 

#include<iostream>
#include<cstdio>
#include<vector>
#include<set>
#include<map>
#include<string.h>
#include<cmath>
#include<algorithm>
#include<queue>
#include<stack>
#define LL long long
#define mod 1000000007
#define inf 0x3f3f3f3f

using namespace std;

double num[100];
double dp[600][3];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        int k1,k2,k3,a,b,c;
        scanf("%d%d%d%d%d%d%d",&n,&k1,&k2,&k3,&a,&b,&c);
        memset(num,0,sizeof(num));
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=k1;i++)
            for(int j=1;j<=k2;j++)
                for(int k=1;k<=k3;k++)
                {
                    if(i==a&&j==b&&k==c)
                        continue;
                    num[i+j+k]++;
                }
        int p=k1+k2+k3;
        double q=k1*k2*k3;
        for(int i=3;i<=p;i++)
        {
            num[i]/=q;
        }
        for(int i=n+p;i>=0;i--)
        {
            if(i>n)
            {
                dp[i][1]=0;
                dp[i][2]=0;
            }
            else
            {
                for(int j=3;j<=p;j++)
                {
                    dp[i][1]+=num[j]*dp[i+j][1];
                    dp[i][2]+=num[j]*dp[i+j][2];
                }
                dp[i][1]++;
                dp[i][2]+=1/q;
            }
        }
        printf("%.15lf\n",dp[0][1]/(1.0-dp[0][2]));
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/brotherHaiNo1/p/8458750.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值