poj1472--Instant Complexity(模拟)

 Instant Complexity
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

 

Appoint description:  

Description

Analyzing the run-time complexity of algorithms is an important tool for designing efficient programs that solve a problem. An algorithm that runs in linear time is usually much faster than an algorithm that takes quadratic time for the same task, and thus should be preferred.  

Generally, one determines the run-time of an algorithm in relation to the `size' n of the input, which could be the number of objects to be sorted, the number of points in a given polygon, and so on. Since determining a formula dependent on n for the run-time of an algorithm is no easy task, it would be great if this could be automated. Unfortunately, this is not possible in general, but in this problem we will consider programs of a very simple nature, for which it is possible. Our programs are built according to the following rules (given in BNF), where < number > can be any non-negative integer:  
< Program > ::= "BEGIN" < Statementlist > "END" 

< Statementlist > ::= < Statement > | < Statement > < Statementlist > 

< Statement > ::= < LOOP-Statement > | < OP-Statement > 

< LOOP-Statement > ::= < LOOP-Header > < Statementlist > "END" 

< LOOP-Header > ::= "LOOP" < number > | "LOOP n" 

< OP-Statement > ::= "OP" < number >

The run-time of such a program can be computed as follows: the execution of an OP-statement costs as many time-units as its parameter specifies. The statement list enclosed by a LOOP-statement is executed as many times as the parameter of the statement indicates, i.e., the given constant number of times, if a number is given, and n times, if n is given. The run-time of a statement list is the sum of the times of its constituent parts. The total run-time therefore generally depends on n.  

Input

The input starts with a line containing the number k of programs in the input. Following this are k programs which are constructed according to the grammar given above. Whitespace and newlines can appear anywhere in a program, but not within the keywords BEGIN, END, LOOP and OP or in an integer value. The nesting depth of the LOOP-operators will be at most 10.

Output

For each program in the input, first output the number of the program, as shown in the sample output. Then output the run-time of the program in terms of n; this will be a polynomial of degree Y <= 10. Print the polynomial in the usual way, i.e., collect all terms, and print it in the form "Runtime = a*n^10+b*n^9+ . . . +i*n^2+ j*n+k", where terms with zero coefficients are left out, and factors of 1 are not written. If the runtime is zero, just print "Runtime = 0".  
Output a blank line after each test case.

Sample Input

2
BEGIN
  LOOP n
    OP 4
    LOOP 3
      LOOP n
        OP 1
      END
      OP 2
    END
    OP 1
  END
  OP 17
END

BEGIN
  OP 1997 LOOP n LOOP n OP 1 END END
END

Sample Output

Program #1
Runtime = 3*n^2+11*n+17

Program #2
Runtime = n^2+1997

 

 

 计算时间复杂度,只有执行语句和循环,执行语句OP后为一个非负整数,循环LOOP后为一个非负整数或n,计算整个程序的复杂度。

做一个栈,记录下当前的复杂度,没遇到OP就计算出当前的复杂度,累加起来。控制输出、

 

 

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <stack>
using namespace std ;
stack <int> sta ;
int c[15] , a , b ;//
char str[10] ;
int main()
{
    int t , tt , temp , k , i , j , l ;
    scanf("%d", &t) ;
    for( tt = 1 ; tt <= t ; tt++ )
    {
        while( !sta.empty() ) sta.pop() ;
        memset(c,0,sizeof(c)) ;
        a = 1 ;
        b = 0 ;
        temp = 0 ;
        scanf("%s", str) ;
        while( temp >= 0 )
        {
            scanf("%s", str) ;
            if( strcmp(str,"LOOP") == 0 )
            {
                temp++ ;
                scanf("%s", str) ;
                if( str[0] == 'n' )
                {
                    b++ ;
                    sta.push(-1) ;
                }
                else
                {
                    k = 0 ;
                    l = strlen(str) ;
                    for(i = 0 ; i < l ; i++)
                    {
                        k = k*10 + str[i] - '0' ;
                    }
                    if( k == 0 )
                        sta.push(a) ;
                    a *= k ;
                    sta.push(k) ;
                }
            }
            else if( strcmp(str,"OP") == 0 )
            {
                scanf("%s", str) ;
                k = 0 ;
                l = strlen(str) ;
                for(i = 0 ; i < l ; i++)
                    k = k*10 + str[i] - '0' ;
                c[b] += k*a ;
            }
            else
            {
                temp-- ;
                if( temp == -1 )
                    continue ;
                if( sta.top() == 0 )
                {
                    sta.pop() ;
                    a = sta.top() ;
                    sta.pop() ;
                }
                else if( sta.top() == -1 )
                {
                    sta.pop() ;
                    b-- ;
                }
                else
                {
                    a /= sta.top() ;
                    sta.pop() ;
                }
            }
        }
        printf("Program #%d\n", tt) ;
        printf("Runtime = ") ;
        int flag = 0 ;
        for(i = 14 ; i >= 0 ; i--)
        {
            if( c[i] == 0 ) continue ;
            if( flag )
                printf("+") ;
            if( i == 0 )
            {
                printf("%d", c[i]);
            }
            else
            {
                if( c[i] > 1 )
                    printf("%d", c[i]) ;
                if( i != 0 )
                {
                    if( c[i] > 1 )
                        printf("*");
                    printf("n") ;
                    if( i > 1 )
                        printf("^%d", i) ;
                }
            }
            flag = 1 ;
        }
        if( flag == 0 )
            printf("0") ;
        printf("\n") ;
        if( tt < t )
            printf("\n") ;
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值