贪心——Radar Installation

Radar Installation
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 50093 Accepted: 11220

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 
 
Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

Source


题意:
以X轴为岸边,X轴以上部分为海洋,海洋上分布着小岛,现在要在岸边建立雷达监视小岛,问至少要建多少雷达。
思路:
雷达的监控范围是以D为半径的圆。则以小岛为圆心,以D为半径画圆,这个圆与X轴的交点区间就是可以放置雷达的区间,若小岛的Y大于D,则无论如何都与X轴没有交点,则不会完全覆盖。
在都有交点的前提下,这些区间就转换成了最基本的贪心问题——选活动,一个区间的起点大于前面所有区间的起点终点,则应该在建设一个雷达。
#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <math.h>

using namespace std;

struct node
{
    double qd;
    double zd;
};
struct node cun[1000000];

int cmp(struct node i,struct node j)
{
    return i.zd < j.zd;
}

int main()
{
    double x,y,d,bj,j;
    int i,k,num,n;
    double xx;
    for(k = 1;; k++)
    {
        scanf("%d%lf",&n,&d);
        bj = 1;
        num = 0;
        if(n == 0 && d == 0)
            break;
        for(i = 0; i < n; i++)
        {
            scanf("%lf%lf",&x,&y);
            if(y > d)
                bj = 0;
            xx = sqrt(d * d - y * y);
            cun[i].qd = x - xx;
            cun[i].zd = x + xx;
        }
        if(bj == 0)
            printf("Case %d: -1\n",k);
        else
        {
            sort(cun,cun+n,cmp);
            j = cun[0].zd;
            num++;
            for(i = 1; i < n; i++)
            {
                if(cun[i].qd > j)
                {
                    num++;
                    j = cun[i].zd;
                }
            }
            printf("Case %d: %d\n",k,num);
        }
    }
    return 0;
}


贪心算法是一种问题求解方法,它在每一步总是做出当前情况下的最优选择,以期望获得最优解。而"最大整数"同样可以使用贪心算法来求解。 对于"最大整数"的问题,我们可以考虑如下的贪心策略:从高位开始,尽可能选择较大的数字。具体步骤如下: 1. 对于给定的整数,我们首先将其转化为一个数组,其中每个元素表示整数的一个位数。 2. 从最高位(最左侧)开始,遍历数组。 3. 对于当前位上的数字,从9开始递减,找到第一个小于等于当前数字的最大数字。 4. 如果找到了符合条件的最大数字,将其放在当前位。否则,不做任何操作。 5. 继续向下遍历,重复步骤3-4。 6. 最终,得到的数组即为满足条件的最大整数。 以一个具体的例子说明上述算法:假设给定的整数为5372。 1. 将整数转化为数组[5, 3, 7, 2]。 2. 从最高位开始遍历。 3. 对于第一位5,从9开始递减,找到第一个小于等于5的数字,为7。 4. 将7放在第一位,得到[7, 3, 7, 2]。 5. 对于第二位3,从9开始递减,找到第一个小于等于3的数字,为3(与当前数字相等)。 6. 不做任何操作,得到[7, 3, 7, 2]。 7. 对于第三位7,从9开始递减,找到第一个小于等于7的数字,为7。 8. 将7放在第三位,得到[7, 3, 7, 2]。 9. 对于第四位2,从9开始递减,找到第一个小于等于2的数字,为2。 10. 将2放在第四位,得到[7, 3, 7, 2]。 11. 遍历结束,最终得到的数组为[7, 3, 7, 2],转化为整数为7372。 通过上述贪心算法,我们得到了满足条件的最大整数7372。证明了贪心算法在"最大整数"问题中的有效性。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值