贪心算法002:Radar Installation

002:Radar Installation

总时间限制: 1000ms 内存限制: 65536kB
描述
Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

Figure A Sample Input of Radar Installations
输入
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros
输出
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. “-1” installation means no solution for that case.
样例输入
3 2
1 2
-3 1
2 1

1 2
0 2

0 0
样例输出
Case 1: 2
Case 2: 1

解题思路:
该题求能覆盖到岛屿的最少雷达数;
贪心算法:
1.放置能覆盖到最多岛屿的雷达,使得放置的雷达数最少;
2.计算各个岛屿可放置的雷达区域,将雷达放置重叠处即可以减少数量;

解题要点:
1.创建数组island,保存每个岛屿可被覆盖的雷达范围,
2.创建结构Island,包含x轴上能覆盖该岛屿的范围(start,end),
2.按每个island的起点排序
3.设定一个变量e,保存当前最小的end,当e<start时,放置一个雷达,e=当前end

#include<iostream>
#include<algorithm>
#include<cmath> 
using namespace std; 				
struct Island{
	double start,end;
	bool operator<(const Island &i) const{
	return start < i.start;                   //设定结构按照start大小排序 
	} 	
};	 
Island il[1010];
int n,d;
double e;        		//e用来判断雷达是否能覆盖到前面的所有点 
double xy[1010][2];
int result; 
double Num;
int C=0;
int flag=0;

int main(){
	while(cin>>n>>d){
	C++;                     //C++放最前面比较好 
	flag=0;
		if(n==0&d==0) return 0;        //结束情况 
	for (int i=0;i<n;i++){
		cin>>xy[i][0]>>xy[i][1];
		if(xy[i][1]>d){                                                
		//失败情况1:直角边大于斜边 
			flag=1;             //标记一个flag,但是还是要把cin全部拿走 
		}
		Num=sqrt((d*d-xy[i][1]*xy[i][1]));
		il[i].start=xy[i][0]-Num;                          //计算es 
		il[i].end=xy[i][0]+Num;
	}		
	if(n<0||d<0) {                                                    
	//失败情况2:给的数据小于0 
		flag=1;
		}
	if(flag==1) {                                                     
	//当出现失败情况时——输出失败,且跳过下面的步骤 
					cout<<"Case "<<C<<": -1"<<endl;
					continue;
	}
	sort(il,il+n);                   
	//il 按照start排序  ,start排序过后就没有用处了 
	e=il[0].end;            		
	//设定结束点 ,依靠结束点判断需不需要放置雷达 
	result=0;          				
	//记录当前需要几个result
	for(int i=1;i<n;i++){
		//分类讨论    1.该节点的起始点比e小,比较该节点的end与e,取小的为e 
	//2.i节点的起始点比e大——需要放置雷达,则result++
		if(il[i].start<=e){
			e=min(e,il[i].end);
		}                      
		else{
			//il[i-1]的start放置一个雷达 
			result++;
			e=il[i].end;               //将e改为当前点的end; 
		} 
	}
	result++;
	cout<<"Case "<<C<<": "<<result<<endl;
}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值