并查集——Ubiquitous Religions

Ubiquitous Religions
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 22821 Accepted: 11254

Description

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in. 

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

Input

The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.

Output

For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

Sample Input

10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0

Sample Output

Case 1: 1
Case 2: 7

Hint

Huge input, scanf is recommended.

题意:
调查学校里的学生信仰情况,给出的是两个人的信仰相同,计算最多有多少种信仰。

并查集的知识已经在上一篇博客中写过了,现在直接贴代码:
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <math.h>

int bj[50009];

int fin(int x)
{
    int r;
    r = x;
    while(bj[r] != r)//查找根节点,只有下表和内容相同的才会是根节点
        r = bj[r];
    return r;
}

void bing(int x,int y)
{
    int fx,fy;
    fx = fin(x);//查找x的根节点
    fy = fin(y);//查找y的根节点
    if(fx != fy)//如果x的根节点和y的根节点不相同,则合并两个集合
    {
        bj[fx] = fy;//将x所在的树合并到y所在的树下,也就是把x的根节点改成y的根节点
    }
}
int main()
{
    int n,m,i,j,k,x,y,t = 0;
    while(~scanf("%d%d",&n,&m))
    {
        if(n == 0 && m == 0)
            break;
        t++;
        for(i = 0; i <= n; i++)
            bj[i] = i;
        for(i = 0; i < m; i++)
        {
            scanf("%d%d",&x,&y);
            bing(x,y);
        }
        int num = 0;
        for(i = 0; i < n; i++)
        {
            if(bj[i] == i)//计算在这个并查集森林中,一共有多少棵树
                num++;
        }
        printf("Case %d: %d\n",t,num);
    }
    return 0;
}

扩展:
如果此题目是询问两个人的信仰是否相同,这就需要对并查集进行根节点的查询,下面展示普通的以及优化的代码:
//这是普通的查询
int find(int x)//两次调用此函数,分别传入x,y,返回他们的根节点,在主函数中进行判断,如果相同,则信仰相同。
{
    int r = x;
    while(bj[r] != r)
        r = bj[r];
    return r;
}

//但是如果查询的次数达到上万次,则就有可能会超时,下面是优化过的代码
int find(int x)
{
    int r = x;
    while(bj[r] != r)
        r = bj[r];
    int k = x,j;
    while(k != r)//按照上次的顺序再次遍历一遍,把每个子节点存储的值都变成根节点存储的值。
    {
        j = bj[k];
        bj[k] = r;
        k = j;
    }
    return r;
}
//这样,只需要判断两个节点下存储的值是不是相同就可以了。个人认为,在建立关系的时候最好就这么办。


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
项目:使用AngularJs编写的简单 益智游戏(附源代码)  这是一个简单的 javascript 项目。这是一个拼图游戏,也包含一个填字游戏。这个游戏玩起来很棒。有两个不同的版本可以玩这个游戏。你也可以玩填字游戏。 关于游戏 这款游戏的玩法很简单。如上所述,它包含拼图和填字游戏。您可以通过移动图像来玩滑动拼图。您还可以选择要在滑动面板中拥有的列数和网格数。 另一个是填字游戏。在这里你只需要找到浏览器左侧提到的那些单词。 要运行此游戏,您需要在系统上安装浏览器。下载并在代码编辑器中打开此项目。然后有一个 index.html 文件可供您修改。在命令提示符中运行该文件,或者您可以直接运行索引文件。使用 Google Chrome 或 FireFox 可获得更好的用户体验。此外,这是一款多人游戏,双方玩家都是人类。 这个游戏包含很多 JavaScript 验证。这个游戏很有趣,如果你能用一点 CSS 修改它,那就更好了。 总的来说,这个项目使用了很多 javascript 和 javascript 库。如果你可以添加一些具有不同颜色选项的级别,那么你一定可以利用其库来提高你的 javascript 技能。 演示: 该项目为国外大神项目,可以作为毕业设计的项目,也可以作为大作业项目,不用担心代码重复,设计重复等,如果需要对项目进行修改,需要具备一定基础知识。 注意:如果装有360等杀毒软件,可能会出现误报的情况,源码本身并无病毒,使用源码时可以关闭360,或者添加信任。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值