并查集---宗教信仰

并查集—宗教信仰

题目:

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in.

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

Input

The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.

Output

For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

Sample Input

10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0

Sample Output

Case 1: 1
Case 2: 7

Hint

Huge input, scanf is recommended.

题意:

找出最多有多少种不同的宗教信仰。

思路:

将同一信仰的学生合并为一组,(即先将数组初始化为数组的下标,若遇到相同信仰的人就将其下标统一改成同一个固定下标,以便最后统计),最终for循环遍历一遍输出最终结果即可。

代码:

#include<stdio.h>
int f[50001],m,n,sum;
void init()
{
	int i;
	for(i=1;i<=n;i++)
	f[i]=i;   //将数组初始化为其下标
	return;
}
int getf(int k)//递归函数找爹,不停地去找爹,直到找到祖宗为止
{
	if(f[k]==k)
	return k;
	else
	{
		f[k]=getf(f[k]);//这里进行了路径压缩,提高寻找速度
		return f[k];
	}
}
void merge(int v,int u)
{
	int a,b;  //a,b分别为v和u的祖先,每次双方的会谈都必须是各自祖先级才行
	a=getf(v);
	b=getf(u);
	if(a!=b)//判断两个节点是否在同一个集合中,即是否为同一个祖先
		f[b]=a;   //把右边的集合作为左边集合的子集合
	return;
}
int main()
{
	int i,x,y,s=0;
	while(~scanf("%d%d",&n,&m)&&n&&m)
	{
		s++;    //记录测试样例的个数
		sum=0;
		init();    //必须初始化
		for(i=1;i<=m;i++)
		{
			scanf("%d%d",&x,&y);//开始合并拥有同一个宗教信仰的人
			merge(x,y);
		}
		for(i=1;i<=n;i++)//最后扫描有多少个宗教
		{
			if(f[i]==i)
			sum++;
		}
		printf("Case %d: %d\n",s,sum);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值