模拟——Parencodings

Parencodings
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 19185 Accepted: 11570

Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways: 
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence). 
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence). 

Following is an example of the above encodings: 
	S		(((()()())))

	P-sequence	    4 5 6666

	W-sequence	    1 1 1456


Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string. 

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9 
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9

Source


题意:
给出每一个右括号前边的左括号数目,输出包含每一个右括号的左边的最大括号匹配数目。
思路:
根据给出的数目,将括号的排列还原出来,依次找到每一个右括号,将这个右括号存入栈里,往左遍历,遇到右括号则入栈,遇到左括号则将栈顶的右括号出栈,并将计数器加1,如果栈空,则打印计数器。
代码:
#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
using namespace std;

char sz[1000000];
char zhan[1000000];

int main()
{
    int n,t,i,j,k,m,f,p,x;
    int top;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        k = 0;
        f = 0;
        for(i = 1; i <= n; i++)
        {
            scanf("%d",&m);
            x = m - f;
            f = m;
           for(p = 0;p < x;p++)
            {
                sz[k++] = '(';
            }
            sz[k++] = ')';
        }
        sz[k] = '\0';
        p = 0;
        for(i = 0; i < k; i++)
        {
            if(sz[i] == ')')
            {
                top = -1;
                int num = 0;
                zhan[++top] = sz[i];//当时就是把这个i手残写成了j,交了三遍RE,关键是还很巧合的把样例给过了。。。。。。
                for(j = i-1; j >= 0; j--)
                {
                    if(sz[j] == ')')
                        zhan[++top] = sz[j];
                    else if(sz[j] == '(')
                    {
                        top--;
                        num++;
                    }
                    if(top == -1 && p == 0)
                    {
                        printf("%d",num);
                        p++;
                        break;
                    }
                    else if(top == -1 && p != 0)
                    {
                        printf(" %d",num);
                        break;
                    }
                }
            }
        }
        printf("\n");
    }
    return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值