【九度】题目1001:A+B for Matrices

108 篇文章 0 订阅
102 篇文章 5 订阅
题目1001:A+B for Matrices
时间限制
:1 秒内存限制:32 兆特殊判题:否提交:13336解决:5429
题目描述
    This time, you are supposed to find A+B where A and B are two matrices, and then count the number of zero rows and columns.
输入
    The input consists of several test cases, each starts with a pair of positive integers M and N (≤10) which are the number of rows and columns of the matrices, respectively. Then 2*M lines follow, each contains N integers in [-100, 100], separated by a space. The first M lines correspond to the elements of A and the second M lines to that of B.
    The input is terminated by a zero M and that case must NOT be processed.
输出
    For each test case you should output in one line the total number of zero rows and columns of A+B.
样例输入
2 2
1 1
1 1
-1 -1
10 9
2 3
1 2 3
4 5 6
-1 -2 -3
-4 -5 -6
0
样例输出
1
5
来源
2011年浙江大学计算机及软件工程研究生机试真题
答疑:
解题遇到问题?分享解题心得?讨论本题请访问:http://t.jobdu.com/thread-7724-1-1.html
【解题思路】
矩阵相加,求整行和整列为0的行列数。

Java AC

import java.io.BufferedReader;
import java.io.InputStreamReader;
import java.io.StreamTokenizer;
 
public class Main{
    /*
     * 1002 2014年07月16日16:20:45
     */
    public static void main(String[] args) throws Exception{
        StreamTokenizer st = new StreamTokenizer(new BufferedReader(
                    new InputStreamReader(System.in)));
        while(st.nextToken() != StreamTokenizer.TT_EOF){
            int m = (int)st.nval;
            if(m == 0){
                break;
            }
            st.nextToken();
            int n = (int)st.nval;
            int matrix[][] = new int[m][n];
            for(int i = 0 ; i < m; i++){
                for(int j = 0; j < n; j++){
                    st.nextToken();
                    matrix[i][j] = (int)st.nval;
                }
            }
 
            for(int i = 0 ; i < m; i++){
                for(int j = 0; j < n; j++){
                    st.nextToken();
                    matrix[i][j] += (int)st.nval;
                }
            }
            int zeroNum = 0;
            for (int i = 0; i < m; i++) {
                boolean isZero = true;
                for (int j = 0; j < n; j++) {
                    if (matrix[i][j] != 0) {
                        isZero = false;
                        break;
                    }
                }
                if (isZero) {
                    zeroNum++;
                }
            }
            for (int j = 0; j < n; j++) {
                boolean isZero = true;
                for (int i = 0; i < m; i++) {
                    if (matrix[i][j] != 0) {
                        isZero = false;
                        break;
                    }
                }
                if (isZero) {
                    zeroNum++;
                }
            }
            System.out.println(zeroNum);
        }
    }
}
/**************************************************************
    Problem: 1001
    User: wangzhenqing
    Language: Java
    Result: Accepted
    Time:690 ms
    Memory:14584 kb
****************************************************************/
C++ AC

#include <stdio.h>
const int max = 102;
int matrix[max][max];
int m, n;
int i, j;
int main(){
    while(scanf("%d", &m) != EOF){
        if(m == 0){
            break;
        }
        scanf("%d", &n);
        for(i = 0 ; i < m; i++){
            for(j = 0; j < n; j++){
                scanf("%d", &matrix[i][j]);
            }
        }
 
        for(i = 0 ; i < m; i++){
            for(int j = 0; j < n; j++){
                int tempNum;
                scanf("%d", &tempNum);
                matrix[i][j] += tempNum;
            }
        }
        int zeroNum = 0;
        for (i = 0; i < m; i++) {
            bool isZero = true;
            for (j = 0; j < n; j++) {
                if (matrix[i][j] != 0) {
                    isZero = false;
                    break;
                }
            }
            if (isZero) {
                zeroNum++;
            }
        }
        for (j = 0; j < n; j++) {
            bool isZero = true;
            for (int i = 0; i < m; i++) {
                if (matrix[i][j] != 0) {
                    isZero = false;
                    break;
                }
            }
            if (isZero) {
                zeroNum++;
            }
        }
        printf("%d\n", zeroNum);
    }
    return 0;
}
/**************************************************************
    Problem: 1001
    User: wangzhenqing
    Language: C++
    Result: Accepted
    Time:0 ms
    Memory:1060 kb
****************************************************************/



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值