【贪心专题】POJ 1328 G - Radar Installation (区间覆盖)

链接:click here~~

题意:

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.
\
Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1
【解题思路】

这道题描述是这样的:
在给定的一条海岸线两侧分别是海跟陆地,在海里有若干个用x,y坐标标示位置的岛屿,岸上安排雷达站,每个雷达站有自己的覆盖范围,最大范围是以半径d形成的圆。要求求出最少需要多少个雷达站覆盖所有岛屿。
岛屿坐标随机给出。
区间覆盖的贪心问题:
相对原点而言,我们假定x负半轴方向为“左”,x正半轴方向为“右”。
首先对每个点求出能覆盖到这个点的在海岸线上左右两边极限位置的坐标(注意是圆心坐标)。也就是
在雷达(圆)的左半圆上或者在雷达(圆)的右半圆上,换句话说当岛屿到雷达的距离等于d的时候,形成的圆分别会与x轴相交一点,根据这个点可以求出极限坐标:
最左为:x + sqrt(d*d-y*y); 最右为:x - sqrt(d*d-y*y);
每个岛屿都有这样的最左和最右可被侦测坐标。
假定当前的岛屿为a,当前的下一个为next。
      1.如果next的最左边坐标比a的最右边大,只能再设一个雷达来侦测next了,sum++。
      2.如果next的最左边坐标比a的最右边小,这时会有两种情况。
         A.next最右边<a最右边
         B.next最右边>=a最右边
         对于B情况,我们可以直接侦测到a和next,下一步找next的下一个岛屿。
         对于A情况,也就等价于next包含于a, 这样就应该把next的最右边做为衡量标准了.
然后按照左极限位置对这些点排序。然后从左到右找到每个雷达最多能覆盖的岛屿数。最后就得到了所需的雷达数。当有岛屿离海岸的距离大于雷达覆盖半径,则输出不可能
代码:

#include <stdio.h>
#include <string.h>
#include <math.h>
#include <iostream>
#include <algorithm>
using namespace std;
const double pi=acos(-1.0);
const double eps=1e-6;
#define CLR(a,b) sqrt(a*a-b*b)
struct node
{
    double left,right;
} p[1001];
bool cmp(node a,node b)
{
    return a.left<b.left;
}
int main()
{
    int x,y,n,k,tot=1;
    while(~scanf("%d%d",&n,&k),n|k)
    {
        memset(p,0,sizeof(p));
        bool flag=false;
        int sum=1;
        for(int i=1; i<=n; i++)
        {
            scanf("%d%d",&x,&y);
            if(y>k)
            {
                flag=true;
            }
            else
            {
                p[i].left=x-CLR(k,y);
                p[i].right=x+CLR(k,y);
            }
        }
        printf("Case %d: ",tot++);
        if(flag)
        {
            printf("%d\n",-1);
            continue;
        }
        else
        {
            sort(p+1,p+n+1,cmp);
            double ans=p[1].right;
            for(int i=2; i<=n; i++)
            {
                if(p[i].left>ans)
                {
                    sum++;
                    ans=p[i].right;
                }
                else
                {
                    ans=min(ans,p[i].right);
                }
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值