HDU 5430 Reflect

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5430

Problem Description
We send a light from one point on a mirror material circle,it reflects N times and return the original point firstly.Your task is calcuate the number of schemes.


 

Input
First line contains a single integer T(T10) which denotes the number of test cases.

For each test case, there is an positive integer N(N106) .
 

Output
For each case, output the answer.
 

Sample Input
  
  
1 4
 

Sample Output
  
  
4


若入射角为a,则圆心角为2a,由于刚好回到原点,则2a*(N+1)必须为2kπ,其中k可以为任意整数,不难发现,只要a和N+1是互质数即可满足要求,判断是否是互质数我们可以求他们的公约数,如果求不出公约数的话,那就说明它们互质了。代码如下:

#include<iostream>
using namespace std;
int fun(int i,int n){
	int temp;
	while(i!=0&&i!=1){
		temp=n%i;
		n=i;
		i=temp;
	}	
	return i;
}

int main()
{
	int T;
	cin>>T;
	while(T--){
		int n;
		cin>>n;
		int cnt=0;
		for(int i=1;i<=n;i++){
			if(fun(i,n+1)){
		//		cout<<"yes";
				cnt++;
			}
		//	else cout<<"no";
		}
		cout<<cnt<<endl;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值