Description
Two positive integers are said to be relatively prime to each other if the Great Common Divisor (GCD) is 1. For instance, 1, 3, 5, 7, 9...are all relatively prime to 2006.
Now your job is easy: for the given integer m, find the K-th element which is relatively prime to m when these elements are sorted in ascending order.
Now your job is easy: for the given integer m, find the K-th element which is relatively prime to m when these elements are sorted in ascending order.
Input
The input contains multiple test cases. For each test case, it contains two integers m (1 <= m <= 1000000), K (1 <= K <= 100000000).
Output
Output the K-th element in a single line.
Sample Input
2006 1 2006 2 2006 3
Sample Output
1 3 5
根据i与m的最大公约数为love,则i+k*m与m的最大公约数为love;
有除法,注意除数不为0!我RE了,,,,
#include<stdio.h>
int m[1000110];
int gcd(int a1,int b1){
if(b1==0)return a1;
else return gcd(b1,a1%b1);
}
int main(){
int a,b;
int j;
while(~scanf("%d%d",&a,&b)){
j=0;
for(int i=1;i<=a;i++)
if(gcd(a,i)==1)m[j++] = i;
__int64 aa = b/j*a+m[b%j-1];
__int64 bb = (b/j-1)*a+m[j-1];
if(b%j)printf("%I64d\n",aa);
else printf("%I64d\n",bb);
}
}