tarjan+缩点

B - Popular Cows
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

Every cow's dream is to become the most popular cow in the herd. In a herd of N (1 <= N <= 10,000) cows, you are given up to M (1 <= M <= 50,000) ordered pairs of the form (A, B) that tell you that cow A thinks that cow B is popular. Since popularity is transitive, if A thinks B is popular and B thinks C is popular, then A will also think that C is 
popular, even if this is not explicitly specified by an ordered pair in the input. Your task is to compute the number of cows that are considered popular by every other cow. 

Input

* Line 1: Two space-separated integers, N and M 

* Lines 2..1+M: Two space-separated numbers A and B, meaning that A thinks B is popular. 

Output

* Line 1: A single integer that is the number of cows who are considered popular by every other cow. 

Sample Input

3 3
1 2
2 1
2 3

Sample Output

1

在对图进行建立时,如果用矩阵会导致内存超限,用VEC会使后来的缩点变得麻烦,所以用邻接表是最佳选择:

#include<stdio.h>
#include<stack>;
#include<string.h>
using namespace std;
stack<int>S;
int dfn[10005],map[10005][110],low[10005],instack[10005],belong[10005],out[10005];
int index,bnt;
void tarjan(int i){
	dfn[i] = low[i] = ++index;
	S.push(i);
	instack[i] = 1;
	for(int j=1;j<=map[i][0];j++){
		int k = map[i][j];
		if(!dfn[k]){
			tarjan(k);
			low[i] = min(low[i],low[k]);
		}
		else if(instack[k]){
			low[i] = min(low[i],dfn[k]);
		}
		
	}
	if(low[i]  == dfn[i]){
		bnt ++;
		int k;
		do{
		    k = S.top();
			S.pop();
			instack[k] = 0;
			belong[k] = bnt;
		}while(i!=k);
	}
}
int main(){
	int m,n,sum;
	while(~scanf("%d%d",&n,&m)){
		int a,b,j;
	   index = bnt = sum = 0;
		memset(map,0,sizeof(map));
		memset(instack,0,sizeof(instack));
		memset(out,0,sizeof(out));
		memset(dfn,0,sizeof(dfn));
		for(int i=0;i<m;i++){
			scanf("%d%d",&a,&b);
			map[a][++map[a][0]] = b;
		}
		for(int i=1;i<=n;i++)
		if(!dfn[i]){
			tarjan(i);
		}
		for(int i=1;i<=n;i++){
			for(j = 1;j<=map[i][0];j++)
			if(belong[i]!=belong[map[i][j]])
			out[belong[i]]++;
		}
		int z=0;
		for(int i=1;i<=bnt;i++){
			if(out[i]==0){
				z++;
				for(int j=1;j<=n;j++)
				if(belong[j]==i)sum++;
			}
		}
		if(z==1)
		printf("%d\n",sum);
		else printf("0\n");
	
	}
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值