【转载】HDU 2844.Coins(多重背包转01背包)

Link

Problem Description
Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.
 
Input
The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.
 
Output
For each test case output the answer on a single line.
 
Sample Input
   
   
3 10 1 2 4 2 1 1 2 5 1 4 2 1 0 0
 
Sample Output
   
   
8 4
 


//多重背包转01背包

/*

刚小结完,就把这道题目当做是模板使用吧。

和1077一样,贴上解释。

据背包九讲复杂度是O(V*Σn[i])。
本题的特殊性是价值与重量相等
将第i种物品分成若干件物品,其中每件物品有一个系数,
这件物品的费用和价值均是原来的费用和价值乘以这个系数。
使这些系数分别为1,2,4,…,2^(k-1),n[i]-2^k+1,且k是满足n[i]-2^k+1>0的最大整数。
例如,如果n[i]为13,就将这种物品分成系数分别为1,2,4,6的四件物品。
分成的这几件物品的系数和为n[i],表明不可能取多于n[i]件的第i种物品。
另外这种方法也能保证对于0..n[i]间的每一个整数,均可以用若干个系数的和表示

*/

#include <iostream>
#include <cstring>
#include <cmath>
#include <cstdio>
#include <algorithm>
using namespace
std ;

int
f[100005] ;
int
c[105] , num[105] ;
int
n , V ;

void
ZeroOnePack(int cost,int weight)
{

    for
(int v=V ; v >= cost ; v --)
        f[v]=max(f[v],f[v-cost]+weight) ;
}


void
CompletePack(int cost,int weight)
{

    for
(int v=cost ; v <= V ; v ++ )
        f[v]=max(f[v],f[v-cost]+weight) ;
}


void
MultiplePack(int cost,int weight,int amount)
{

    if
( cost*amount>=V )
    {

        CompletePack(cost,weight) ;
        return
;
    }

    int
k=1 ;
    while
( k<amount )
    {

        ZeroOnePack(k*cost,k*weight) ;
        amount=amount-k ;
        k=k*2 ;
    }

    ZeroOnePack(amount*cost,amount*weight) ;
}



int
main()
{

    while
(scanf("%d %d", &n , &V ) && n != 0 && V != 0 )
    {


        for
(int i = 1 ; i <= n ; i ++ )
        {

            scanf( "%d",&c[i]) ;
        }

        for
(int i = 1 ; i <= n ; i ++ )
        {

            scanf( "%d",&num[i]) ;
        }


        memset(f,0,sizeof(f)) ;
        for
(int i = 1 ; i <= n ; i ++)
        {

            MultiplePack(c[i],c[i],num[i]) ;
        }


        int
ans = 0 ;
        for
(int i = 1 ; i <= V ; i ++)
        {

            if
(f[i] == i) ans ++ ;
        }

        printf("%d\n",ans) ;
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值